summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-omxh264dec-allow-to-accept-H.264-stream-in-a-nal-uni.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 18:16:16 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:31:22 +0200
commit770fb50f0ac05731dd1389bfceb171253425855d (patch)
tree2b064bc0596c91f1e0ed3ee2ffd7cb927bf970c9 /common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-omxh264dec-allow-to-accept-H.264-stream-in-a-nal-uni.patch
parent82611ccadef36ab0b8a6fd6fb1cf055e115f1ef5 (diff)
Changes to meta-renesas for building with YP 2.1.1 'krogoth'
Notable changes: - We drop old appends (libgcc_4.8.bbappend, qemu_%.bbappends, gtk+_2.24.%.bbappend) - All gstreamer1.0_1.2.3 related recipes are now in meta-reneas and have been heavily massaged to work with YP 2.1.1 . - systemd needs a patch due to the old kernel - linux-libc-headers needed a patch TODO: - Test and fix Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-omxh264dec-allow-to-accept-H.264-stream-in-a-nal-uni.patch')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-omxh264dec-allow-to-accept-H.264-stream-in-a-nal-uni.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-omxh264dec-allow-to-accept-H.264-stream-in-a-nal-uni.patch b/common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-omxh264dec-allow-to-accept-H.264-stream-in-a-nal-uni.patch
new file mode 100644
index 0000000..0ca832d
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer1.0-omx/0005-omxh264dec-allow-to-accept-H.264-stream-in-a-nal-uni.patch
@@ -0,0 +1,27 @@
+From 5c13ed4eeeb151b5bc648eb6f7262f65903470c4 Mon Sep 17 00:00:00 2001
+From: Kazunori Kobayashi <kkobayas@igel.co.jp>
+Date: Fri, 7 Jun 2013 14:07:57 +0900
+Subject: [PATCH 05/14] omxh264dec: allow to accept H.264 stream in a nal unit
+
+This change allows to set caps to "alignment=nal" in order to
+receive H.264 stream that is split into a nal unit.
+---
+ omx/gstomxh264dec.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/omx/gstomxh264dec.c b/omx/gstomxh264dec.c
+index 2581889..3ed41fc 100644
+--- a/omx/gstomxh264dec.c
++++ b/omx/gstomxh264dec.c
+@@ -61,7 +61,7 @@ gst_omx_h264_dec_class_init (GstOMXH264DecClass * klass)
+
+ videodec_class->cdata.default_sink_template_caps = "video/x-h264, "
+ "parsed=(boolean) true, "
+- "alignment=(string) au, "
++ "alignment=(string) { au, nal }, "
+ "stream-format=(string) byte-stream, "
+ "width=(int) [1,MAX], " "height=(int) [1,MAX]";
+
+--
+1.8.1.2
+