summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly/0001-asfdemux-asfpacket-specify-the-offset-by-an-amount-o.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 18:16:16 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:31:22 +0200
commit770fb50f0ac05731dd1389bfceb171253425855d (patch)
tree2b064bc0596c91f1e0ed3ee2ffd7cb927bf970c9 /common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly/0001-asfdemux-asfpacket-specify-the-offset-by-an-amount-o.patch
parent82611ccadef36ab0b8a6fd6fb1cf055e115f1ef5 (diff)
Changes to meta-renesas for building with YP 2.1.1 'krogoth'
Notable changes: - We drop old appends (libgcc_4.8.bbappend, qemu_%.bbappends, gtk+_2.24.%.bbappend) - All gstreamer1.0_1.2.3 related recipes are now in meta-reneas and have been heavily massaged to work with YP 2.1.1 . - systemd needs a patch due to the old kernel - linux-libc-headers needed a patch TODO: - Test and fix Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly/0001-asfdemux-asfpacket-specify-the-offset-by-an-amount-o.patch')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly/0001-asfdemux-asfpacket-specify-the-offset-by-an-amount-o.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly/0001-asfdemux-asfpacket-specify-the-offset-by-an-amount-o.patch b/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly/0001-asfdemux-asfpacket-specify-the-offset-by-an-amount-o.patch
new file mode 100644
index 0000000..b10e327
--- /dev/null
+++ b/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly/0001-asfdemux-asfpacket-specify-the-offset-by-an-amount-o.patch
@@ -0,0 +1,38 @@
+From 5dbb78388883e2f6e4525b0f322587aa090c3c72 Mon Sep 17 00:00:00 2001
+From: Kazunori Kobayashi <kkobayas@igel.co.jp>
+Date: Wed, 19 Jun 2013 14:10:07 +0900
+Subject: [PATCH 1/2] asfdemux/asfpacket: specify the offset by an amount of
+ filled buffer size when concatenating fragmented media objects
+
+This change is preliminary for inserting VC-1 startcodes of advanced
+profile. To achieve this, the VC-1 startcode size is required to be
+added to the amount of filled buffer size of a payload. As a result
+the offset to concatenate fragmented media objects couldn't be determined
+by mo_offset of an asfpacket, so the offset is specified as the amount
+of filled buffer size instead, which will take account into the VC-1
+start code size.
+---
+ gst/asfdemux/asfpacket.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/gst/asfdemux/asfpacket.c b/gst/asfdemux/asfpacket.c
+index f9b13fb..12eede8 100644
+--- a/gst/asfdemux/asfpacket.c
++++ b/gst/asfdemux/asfpacket.c
+@@ -425,10 +425,10 @@ gst_asf_demux_parse_payload (GstASFDemux * demux, AsfPacket * packet,
+ "offset=%u vs buf_filled=%u", payload.mo_offset,
+ prev->buf_filled);
+ }
+- gst_buffer_fill (prev->buf, payload.mo_offset,
++ gst_buffer_fill (prev->buf, prev->buf_filled,
+ payload_data, payload_len);
+- prev->buf_filled =
+- MAX (prev->buf_filled, payload.mo_offset + payload_len);
++ if ((payload.mo_offset + payload_len) > prev->buf_filled)
++ prev->buf_filled += payload_len;
+ GST_LOG_OBJECT (demux, "Merged media object fragments, size now %u",
+ prev->buf_filled);
+ }
+--
+1.8.1.2
+