summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/libshmeram/libshmeram_git.bb
diff options
context:
space:
mode:
authorNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
committerNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
commit1c35920d85e424b3f65aa6df1dbde689dd6ec007 (patch)
tree58b2cacb3674111aad5a4ded694db0cef5cf55f3 /common/recipes-multimedia/libshmeram/libshmeram_git.bb
commit BSP v1.8.0
Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
Diffstat (limited to 'common/recipes-multimedia/libshmeram/libshmeram_git.bb')
-rw-r--r--common/recipes-multimedia/libshmeram/libshmeram_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/common/recipes-multimedia/libshmeram/libshmeram_git.bb b/common/recipes-multimedia/libshmeram/libshmeram_git.bb
new file mode 100644
index 0000000..2d9873f
--- /dev/null
+++ b/common/recipes-multimedia/libshmeram/libshmeram_git.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "library for accessing the SH-Mobile MERAM"
+AUTHOR = "Damian Hobson-Garcia <dhobsong@igel.co.jp>"
+BUGTRACKER = ""
+
+SECTION = "libs"
+PRIORITY = "optional"
+
+PR = "r1"
+
+inherit autotools pkgconfig
+
+LICENSE = "LGPLv2.0+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3214f080875748938ba060314b4f727d"
+
+SRCREV = "c7d54646cddfc6759ef64a6c22a3ea9e2c61888c"
+SRCREV_armadillo800eva = "890bbd50e3a305a2331a4e2016ead968bdf916bb"
+SRC_URI = "git://github.com/renesas-devel/libshmeram.git \
+ file://configfile-path.patch \
+ "
+S = "${WORKDIR}/git/"
+
+DEPENDS = "libuiomux"
+
+do_configure() {
+ autoreconf -ivf ${S}
+ oe_runconf
+}
+
+# install to libshmeram
+FILES_${PN} += "${sysconfdir}/*"