summaryrefslogtreecommitdiffstats
path: root/common/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2016-10-14 14:25:21 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-11 19:01:50 +0000
commitf71d907312e8dfc30a2e18642a2d4cc4abac01fc (patch)
treec91cf3e8d6a1db2908f722fc8c829090c72d7481 /common/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
parent2420779506844c8b8cf2f50d8f08b622dc6468f6 (diff)
add backport of libnl
* libnl 3.2.28 are not compatible with kernel 3.10 * backport libnl from yocto krogoth Change-Id: If446f6695bc0b51cd4a6b5e5ff87baaa26daa201 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'common/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch')
-rw-r--r--common/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/common/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch b/common/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
new file mode 100644
index 0000000..79aa0bd
--- /dev/null
+++ b/common/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
@@ -0,0 +1,36 @@
+Upstream-Status: Inappropriate [configuration]
+
+libnl has progressed to 0.3.2 and there does not appear to be any
+"make -j" issues with this build after my limited testing on that
+newer version so we can assume this issue is fixed upstream
+
+Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
+
+Index: libnl-3.2.25/lib/Makefile.am
+===================================================================
+--- libnl-3.2.25.orig/lib/Makefile.am
++++ libnl-3.2.25/lib/Makefile.am
+@@ -46,9 +46,12 @@ CLEANFILES = \
+
+ # Hack to avoid using ylwrap. It does not function correctly in combination
+ # with --header-file=
++route/pktloc.lo: route/pktloc_syntax.h route/pktloc_grammar.h
++route/pktloc_grammar.h: route/pktloc_grammar.c
+ route/pktloc_grammar.c: route/pktloc_grammar.l
+ $(AM_V_GEN) $(MKDIR_P) route; $(FLEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+
++route/pktloc_syntax.h: route/pktloc_syntax.c
+ route/pktloc_syntax.c: route/pktloc_syntax.y
+ $(AM_V_GEN) $(MKDIR_P) route; $(YACC) -d $(YFLAGS) -o $@ $^
+
+@@ -102,7 +105,9 @@ BUILT_SOURCES = \
+ route/cls/ematch_grammar.c \
+ route/cls/ematch_syntax.c \
+ route/pktloc_grammar.c \
+- route/pktloc_syntax.c
++ route/pktloc_syntax.c \
++ route/pktloc_syntax.h \
++ route/pktloc_grammar.h
+
+ EXTRA_DIST = \
+ route/pktloc_grammar.l \