summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2017-01-13 15:28:04 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-16 12:25:42 +0000
commit35289ad4e94bbabf1dfa88e71d5d8bd05964aaa4 (patch)
treef876d1fd6b9b76d67177abcf99a9b52ac699535a /common
parent30ed2cf421f8e817e3c93fc095b5fbd34deff2ad (diff)
replace deprecated function base_contains
* replace base_contains by bb.utils.contains * base_contains is deprecated use bb.utils.contains instead * yocto version: 2.2 Change-Id: Ida44a8ded5040cb8bcc1e6140dcbdc795463ce9a Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
Diffstat (limited to 'common')
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bbappend4
-rw-r--r--common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bbappend4
-rw-r--r--common/recipes-multimedia/omxil-sh/omxil-sh_git.bb2
3 files changed, 5 insertions, 5 deletions
diff --git a/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bbappend b/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bbappend
index 2f46ba3..ae95283 100644
--- a/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bbappend
+++ b/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bbappend
@@ -1,5 +1,5 @@
PACKAGECONFIG ??= " \
- ${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
- ${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)} \
ivorbis ogg theora vorbis \
"
diff --git a/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bbappend b/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bbappend
index 910b031..c67449f 100644
--- a/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bbappend
+++ b/common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bbappend
@@ -1,5 +1,5 @@
PACKAGECONFIG ??= " \
- ${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
- ${@base_contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
cairo flac gdk-pixbuf jpeg libpng soup speex taglib \
"
diff --git a/common/recipes-multimedia/omxil-sh/omxil-sh_git.bb b/common/recipes-multimedia/omxil-sh/omxil-sh_git.bb
index e65072b..96124f5 100644
--- a/common/recipes-multimedia/omxil-sh/omxil-sh_git.bb
+++ b/common/recipes-multimedia/omxil-sh/omxil-sh_git.bb
@@ -23,7 +23,7 @@ SRCREV_armadillo800eva = "bd43cfba750773cd323fb546f279e76b37c6d713"
SRC_URI_append_armadillo800eva = " file://vcp1-library-change.patch"
CHECK_OMXIL_SH_MW = "${USE_RENESAS_MW_VCP1}"
CHECK_OMXIL_SH_MW += "${USE_RENESAS_MW_VPU5}"
-DEPENDS_append_armadillo800eva = ' ${@base_contains("CHECK_OMXIL_SH_MW", "1", "vcp1", "", d)}'
+DEPENDS_append_armadillo800eva = ' ${@bb.utils.contains("CHECK_OMXIL_SH_MW", "1", "vcp1", "", d)}'
inherit autotools pkgconfig