summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2/recipes-graphics/gles-module/gles-test-module.bb
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-04-21 16:32:43 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-04-26 21:02:41 +0000
commit39902b66a174446a49e1083c357d86b74daef425 (patch)
treec73408c05ed25ca52385bba68e0da2137dc8c428 /meta-rcar-gen2/recipes-graphics/gles-module/gles-test-module.bb
parent118df1f34368be06401824a6c5b2bb670e53be81 (diff)
BSP's should not ship files in /usr/local/dab_3.99.1dab/3.99.13.99.1
* replace /usr/local with path /usr/share/renesas using: RENESAS_DATADIR = "/usr/share/renesas" - meta-rcar-gen2/include/rcar-gen2-path-common.inc Bug-AGL: SPEC-533 Change-Id: I66350e850df385e901dc4a0ff56bf04452f90868 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-rcar-gen2/recipes-graphics/gles-module/gles-test-module.bb')
-rw-r--r--meta-rcar-gen2/recipes-graphics/gles-module/gles-test-module.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/gles-module/gles-test-module.bb b/meta-rcar-gen2/recipes-graphics/gles-module/gles-test-module.bb
index 7a8fcb9..6686fb7 100644
--- a/meta-rcar-gen2/recipes-graphics/gles-module/gles-test-module.bb
+++ b/meta-rcar-gen2/recipes-graphics/gles-module/gles-test-module.bb
@@ -5,6 +5,8 @@ PN = "gles-test-module"
PR = "r0"
OPENGLES3 ?= "0"
+require include/rcar-gen2-path-common.inc
+
COMPATIBLE_MACHINE = "(r8a7790|r8a7791|r8a7793|r8a7794)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -22,15 +24,15 @@ do_compile() {
do_install() {
# Copy binary into sysroot
- mkdir -p ${D}/usr/local/bin/
+ mkdir -p ${D}${RENESAS_DATADIR}/bin/
if [ "X${OPENGLES3}" = "X0" ]; then
- cp ${S}/OES2_Texture ${D}/usr/local/bin/
- cp ${S}/FragShaderSample.fsh ${D}/usr/local/bin/
- cp ${S}/VertShaderSample.vsh ${D}/usr/local/bin/
+ cp ${S}/OES2_Texture ${D}${RENESAS_DATADIR}/bin/
+ cp ${S}/FragShaderSample.fsh ${D}${RENESAS_DATADIR}/bin/
+ cp ${S}/VertShaderSample.vsh ${D}${RENESAS_DATADIR}/bin/
else
- cp ${S}/OES3_Texture ${D}/usr/local/bin/
- cp ${S}/OES3_FragShaderSample.fsh ${D}/usr/local/bin/
- cp ${S}/OES3_VertShaderSample.vsh ${D}/usr/local/bin/
+ cp ${S}/OES3_Texture ${D}${RENESAS_DATADIR}/bin/
+ cp ${S}/OES3_FragShaderSample.fsh ${D}${RENESAS_DATADIR}/bin/
+ cp ${S}/OES3_VertShaderSample.vsh ${D}${RENESAS_DATADIR}/bin/
fi
}
@@ -38,7 +40,7 @@ PACKAGES = "\
${PN} \
"
FILES_${PN} = " \
- /usr/local/bin/* \
+ ${RENESAS_DATADIR}/bin/* \
"
RPROVIDES_${PN} += "gles-test-module"
INSANE_SKIP_${PN} += "ldflags"