summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2017-01-13 15:28:04 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-16 12:25:42 +0000
commit35289ad4e94bbabf1dfa88e71d5d8bd05964aaa4 (patch)
treef876d1fd6b9b76d67177abcf99a9b52ac699535a /meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb
parent30ed2cf421f8e817e3c93fc095b5fbd34deff2ad (diff)
replace deprecated function base_contains
* replace base_contains by bb.utils.contains * base_contains is deprecated use bb.utils.contains instead * yocto version: 2.2 Change-Id: Ida44a8ded5040cb8bcc1e6140dcbdc795463ce9a Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb')
-rw-r--r--meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb
index 8a72b12..37e8052 100644
--- a/meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen2/recipes-graphics/gles-module/gles-user-module.bb
@@ -26,23 +26,23 @@ OPENGLES3 ?= "0"
SRC_URI_r8a7790 = '${@base_conditional( "OPENGLES3", "1", \
"file://r8a7790_linux_rgx_binaries_gles3.tar.bz2", \
"file://r8a7790_linux_rgx_binaries_gles2.tar.bz2", d )}'
-SRC_URI_append_r8a7790 = " ${@base_contains("DISTRO_FEATURES", "wayland", " \
+SRC_URI_append_r8a7790 = " ${@bb.utils.contains("DISTRO_FEATURES", "wayland", " \
file://EGL_headers_for_wayland.patch \
file://change-shell.patch \
", "", d)}"
SRC_URI_r8a7791 = "file://r8a7791_linux_sgx_binaries_gles2.tar.bz2"
-SRC_URI_append_r8a7791 = " ${@base_contains("DISTRO_FEATURES", "wayland", " \
+SRC_URI_append_r8a7791 = " ${@bb.utils.contains("DISTRO_FEATURES", "wayland", " \
file://EGL_headers_for_wayland.patch \
", "", d)}"
SRC_URI_r8a7793 = "file://r8a7791_linux_sgx_binaries_gles2.tar.bz2"
-SRC_URI_append_r8a7793 = " ${@base_contains("DISTRO_FEATURES", "wayland", " \
+SRC_URI_append_r8a7793 = " ${@bb.utils.contains("DISTRO_FEATURES", "wayland", " \
file://EGL_headers_for_wayland.patch \
", "", d)}"
SRC_URI_r8a7794 = "file://r8a7794_linux_sgx_binaries_gles2.tar.bz2"
-SRC_URI_append_r8a7794 = " ${@base_contains("DISTRO_FEATURES", "wayland", " \
+SRC_URI_append_r8a7794 = " ${@bb.utils.contains("DISTRO_FEATURES", "wayland", " \
file://EGL_headers_for_wayland.patch \
", "", d)}"
@@ -100,7 +100,7 @@ FILES_${PN}-dev = " \
"
PROVIDES = "virtual/libgles2"
-PROVIDES_append = "${@base_contains("DISTRO_FEATURES", "wayland", "", " virtual/egl", d)}"
+PROVIDES_append = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "", " virtual/egl", d)}"
RPROVIDES_${PN} += "${GLES}-user-module libgles2-mesa libgles2-mesa-dev libgles2 libgles2-dev"
INSANE_SKIP_${PN} += "ldflags already-stripped"
INSANE_SKIP_${PN}-dev += "ldflags"