summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
diff options
context:
space:
mode:
authorStephen Lawrence <stephen.lawrence@renesas.com>2014-11-06 18:22:53 +0000
committerStephen Lawrence <stephen.lawrence@renesas.com>2015-03-25 16:12:12 +0000
commit23dda5ccaeb6f5ec08d4170e02ed4b276db46d36 (patch)
treefb3b686e59500a1c2a36faca6d756cda5a72f27d /meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
parent903a3f5053556c115103ff9afe27118680fdb674 (diff)
mesa: Rename mesa bbappend to use wildcard for minor version
Changed as part of update to YP 1.7
Diffstat (limited to 'meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend')
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
new file mode 100644
index 0000000..c7f7f28
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
@@ -0,0 +1,13 @@
+require ../../include/gles-control.inc
+
+def map_libs(d):
+ if base_conditional('USE_GLES_WAYLAND', "1", "1", "0", d) == "1":
+ return "wayland"
+
+ if base_conditional('USE_GLES_X11', "1", "1", "0", d) == "1":
+ return "x11"
+
+ return "dummy"
+
+MESATARGET := "${@map_libs(d)}"
+include mesa-${MESATARGET}.inc