summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 18:16:16 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:31:22 +0200
commit770fb50f0ac05731dd1389bfceb171253425855d (patch)
tree2b064bc0596c91f1e0ed3ee2ffd7cb927bf970c9 /meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch
parent82611ccadef36ab0b8a6fd6fb1cf055e115f1ef5 (diff)
Changes to meta-renesas for building with YP 2.1.1 'krogoth'
Notable changes: - We drop old appends (libgcc_4.8.bbappend, qemu_%.bbappends, gtk+_2.24.%.bbappend) - All gstreamer1.0_1.2.3 related recipes are now in meta-reneas and have been heavily massaged to work with YP 2.1.1 . - systemd needs a patch due to the old kernel - linux-libc-headers needed a patch TODO: - Test and fix Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch')
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch61
1 files changed, 0 insertions, 61 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch
deleted file mode 100644
index 284ea04..0000000
--- a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 6638c55838b8f5186166b7855fdaf41e0a015e88 Mon Sep 17 00:00:00 2001
-From: Emil Velikov <emil.l.velikov@gmail.com>
-Date: Wed, 28 May 2014 14:36:46 +0100
-Subject: [PATCH] egl_dri2: fix wayland_platform when drm_platform is not set
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The build fails with implicit delaration of drmGetCap (xf86drm.h)
-Were we're including the header only when building the DRM_PLATFORM.
-
-Wayland backend can operate without DRM_PLATFORM so replace the
-guard, and fold in drmGetCap() usage to silence compiler warnings.
-
-Cc: Chad Versace <chad.versace@linux.intel.com>
-Cc: Kristian Høgsberg <krh@bitplanet.net>
-Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
----
- src/egl/drivers/dri2/egl_dri2.c | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/src/egl/drivers/dri2/egl_dri2.c b/src/egl/drivers/dri2/egl_dri2.c
-index f7f2da2..c1497b8 100644
---- a/src/egl/drivers/dri2/egl_dri2.c
-+++ b/src/egl/drivers/dri2/egl_dri2.c
-@@ -35,7 +35,7 @@
- #include <fcntl.h>
- #include <errno.h>
- #include <unistd.h>
--#ifdef HAVE_DRM_PLATFORM
-+#ifdef HAVE_LIBDRM
- #include <xf86drm.h>
- #include <drm_fourcc.h>
- #endif
-@@ -2001,7 +2001,7 @@ dri2_bind_wayland_display_wl(_EGLDriver *drv, _EGLDisplay *disp,
- struct wl_display *wl_dpy)
- {
- struct dri2_egl_display *dri2_dpy = dri2_egl_display(disp);
-- int ret, flags = 0;
-+ int flags = 0;
- uint64_t cap;
-
- (void) drv;
-@@ -2012,11 +2012,13 @@ dri2_bind_wayland_display_wl(_EGLDriver *drv, _EGLDisplay *disp,
- wl_drm_callbacks.authenticate =
- (int(*)(void *, uint32_t)) dri2_dpy->vtbl->authenticate;
-
-- ret = drmGetCap(dri2_dpy->fd, DRM_CAP_PRIME, &cap);
-- if (ret == 0 && cap == (DRM_PRIME_CAP_IMPORT | DRM_PRIME_CAP_EXPORT) &&
-+#ifdef HAVE_LIBDRM
-+ if (drmGetCap(dri2_dpy->fd, DRM_CAP_PRIME, &cap) == 0 &&
-+ cap == (DRM_PRIME_CAP_IMPORT | DRM_PRIME_CAP_EXPORT) &&
- dri2_dpy->image->base.version >= 7 &&
- dri2_dpy->image->createImageFromFds != NULL)
- flags |= WAYLAND_DRM_PRIME;
-+#endif
-
- dri2_dpy->wl_server_drm =
- wayland_drm_init(wl_dpy, dri2_dpy->device_name,
---
-1.9.1