summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2/recipes-graphics/mesa
diff options
context:
space:
mode:
authorNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
committerNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
commit1c35920d85e424b3f65aa6df1dbde689dd6ec007 (patch)
tree58b2cacb3674111aad5a4ded694db0cef5cf55f3 /meta-rcar-gen2/recipes-graphics/mesa
commit BSP v1.8.0
Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
Diffstat (limited to 'meta-rcar-gen2/recipes-graphics/mesa')
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa-dummy.inc0
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa-wayland.inc22
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa-x11.inc4
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_9.2.5.bbappend13
4 files changed, 39 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa-dummy.inc b/meta-rcar-gen2/recipes-graphics/mesa/mesa-dummy.inc
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa-dummy.inc
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa-wayland.inc b/meta-rcar-gen2/recipes-graphics/mesa/mesa-wayland.inc
new file mode 100644
index 0000000..e58535e
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa-wayland.inc
@@ -0,0 +1,22 @@
+# FIXME: can not override PACKAGECONFIG.
+PACKAGECONFIG[gles] = "--enable-gles1 --disable-gles2"
+PACKAGECONFIG[egl] = "--enable-egl --with-egl-platforms=wayland"
+
+# Disable the gbm modules of mesa
+EXTRA_OECONF_rcar-gen2 := "${@'${EXTRA_OECONF}'.replace('--enable-gbm', '--disable-gbm')}"
+# Remove the gbm and egl packages. These are provided in other recipes.
+PACKAGES_remove_rcar-gen2 = "libgbm-dev libgbm libegl-mesa-dev libegl-mesa libegl-dev libegl libgles2-mesa libgles2-mesa-dev"
+
+# Remove the x11 configure
+PACKAGECONFIG_rcar-gen2 := "${@'${PACKAGECONFIG}'.replace('x11', '')}"
+
+do_install_append_rcar-gen2() {
+ # Remove libegl-mesa modules and headers
+ rm -f ${D}/usr/lib/libEGL.la
+ rm -f ${D}/usr/lib/libEGL.so*
+ rm -f ${D}/usr/lib/pkgconfig/egl.pc
+ rm -rf ${D}/usr/include/KHR
+ rm -rf ${D}/usr/include/EGL
+}
+
+# FILES_${PN}-dbg += "${libdir}/src/debug/*"
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa-x11.inc b/meta-rcar-gen2/recipes-graphics/mesa/mesa-x11.inc
new file mode 100644
index 0000000..21c497c
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa-x11.inc
@@ -0,0 +1,4 @@
+# FIXME: can not override PACKAGECONFIG[*]
+PACKAGECONFIG[gles] = "--enable-gles1 --disable-gles2"
+
+PACKAGECONFIG_remove_rcar-gen2 = "egl"
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_9.2.5.bbappend b/meta-rcar-gen2/recipes-graphics/mesa/mesa_9.2.5.bbappend
new file mode 100644
index 0000000..c7f7f28
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa_9.2.5.bbappend
@@ -0,0 +1,13 @@
+require ../../include/gles-control.inc
+
+def map_libs(d):
+ if base_conditional('USE_GLES_WAYLAND', "1", "1", "0", d) == "1":
+ return "wayland"
+
+ if base_conditional('USE_GLES_X11', "1", "1", "0", d) == "1":
+ return "x11"
+
+ return "dummy"
+
+MESATARGET := "${@map_libs(d)}"
+include mesa-${MESATARGET}.inc