aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2/recipes-graphics/wayland/libegl.bb
diff options
context:
space:
mode:
authorNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
committerNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
commit1c35920d85e424b3f65aa6df1dbde689dd6ec007 (patch)
tree58b2cacb3674111aad5a4ded694db0cef5cf55f3 /meta-rcar-gen2/recipes-graphics/wayland/libegl.bb
commit BSP v1.8.0
Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
Diffstat (limited to 'meta-rcar-gen2/recipes-graphics/wayland/libegl.bb')
-rw-r--r--meta-rcar-gen2/recipes-graphics/wayland/libegl.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/wayland/libegl.bb b/meta-rcar-gen2/recipes-graphics/wayland/libegl.bb
new file mode 100644
index 0000000..e79d52d
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/wayland/libegl.bb
@@ -0,0 +1,18 @@
+SUMMARY = "EGL library"
+LICENSE = "Apache-2.0 & MIT"
+LIC_FILES_CHKSUM = "file://egl.c;beginline=5;endline=15;md5=3677623633a6e459b1f60b1e541c4212"
+
+COMPATIBLE_MACHINE = "(r8a7790|r8a7791|r8a7793|r8a7794)"
+
+PROVIDES = "${@base_contains("DISTRO_FEATURES", "wayland", "virtual/egl", "", d)}"
+SRCREV = "ee4bce93878d02a144ae6ebfba1eff28fe9b4442"
+SRC_URI = "git://github.com/thayama/libegl;protocol=git;branch=master \
+ file://0001-libegl-Remove-duplicate-header-files-of-gles-user-mo.patch"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+DEPENDS = "libgbm gles-user-module"