summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2/recipes-multimedia/mmngr-module/mmngr-tp-user-module.bb
diff options
context:
space:
mode:
authorNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
committerNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>2015-03-25 10:47:45 +0900
commit1c35920d85e424b3f65aa6df1dbde689dd6ec007 (patch)
tree58b2cacb3674111aad5a4ded694db0cef5cf55f3 /meta-rcar-gen2/recipes-multimedia/mmngr-module/mmngr-tp-user-module.bb
commit BSP v1.8.0
Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
Diffstat (limited to 'meta-rcar-gen2/recipes-multimedia/mmngr-module/mmngr-tp-user-module.bb')
-rw-r--r--meta-rcar-gen2/recipes-multimedia/mmngr-module/mmngr-tp-user-module.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-multimedia/mmngr-module/mmngr-tp-user-module.bb b/meta-rcar-gen2/recipes-multimedia/mmngr-module/mmngr-tp-user-module.bb
new file mode 100644
index 0000000..515f784
--- /dev/null
+++ b/meta-rcar-gen2/recipes-multimedia/mmngr-module/mmngr-tp-user-module.bb
@@ -0,0 +1,29 @@
+require ../../include/rcar-gen2-modules-common.inc
+
+LICENSE = "CLOSED"
+DEPENDS = "mmngr-kernel-module mmngr-user-module"
+SRC_URI = "file://mmngr-tp-user.tar.bz2"
+
+S = "${WORKDIR}/mmngr"
+
+do_compile() {
+ # Build test kernel module
+ cd ${S}
+ make all ARCH=arm
+}
+
+do_install() {
+ # Copy kernel test program
+ mkdir -p ${D}/usr/local/bin/
+ cp ${S}/mmtp ${D}/usr/local/bin/
+}
+
+PACKAGES = "\
+ ${PN} \
+"
+FILES_${PN} = " \
+ /usr/local/bin/mmtp \
+"
+
+RPROVIDES_${PN} += "mmngr-tp-user-module"
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"