summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 18:16:16 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:31:22 +0200
commit770fb50f0ac05731dd1389bfceb171253425855d (patch)
tree2b064bc0596c91f1e0ed3ee2ffd7cb927bf970c9 /meta-rcar-gen2
parent82611ccadef36ab0b8a6fd6fb1cf055e115f1ef5 (diff)
Changes to meta-renesas for building with YP 2.1.1 'krogoth'
Notable changes: - We drop old appends (libgcc_4.8.bbappend, qemu_%.bbappends, gtk+_2.24.%.bbappend) - All gstreamer1.0_1.2.3 related recipes are now in meta-reneas and have been heavily massaged to work with YP 2.1.1 . - systemd needs a patch due to the old kernel - linux-libc-headers needed a patch TODO: - Test and fix Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-rcar-gen2')
-rw-r--r--meta-rcar-gen2/conf/machine/include/rcar-gen2-providers.inc14
-rw-r--r--meta-rcar-gen2/recipes-connectivity/gupnp/gupnp-dlna_%.bbappend1
-rw-r--r--meta-rcar-gen2/recipes-core/ncurses/ncurses_5.9.bbappend4
-rw-r--r--meta-rcar-gen2/recipes-core/systemd/systemd/0001-Add-missing-define-to-header-of-old-porter-kernel.patch31
-rw-r--r--meta-rcar-gen2/recipes-core/systemd/systemd_%.bbappend2
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa-wayland.inc17
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch61
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_10.6.3/0001-dri2-Fix-fstat-s_ISHCR-implict-declaration-build-err.patch35
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_10.6.3/0001-dri2-wayland-fixup-gcc5-build.patch28
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_11.%.bbappend (renamed from meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend)0
-rw-r--r--meta-rcar-gen2/recipes-kernel/linux-libc-headers/linux-libc-headers_3.10.bb1
-rw-r--r--meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb2
12 files changed, 83 insertions, 113 deletions
diff --git a/meta-rcar-gen2/conf/machine/include/rcar-gen2-providers.inc b/meta-rcar-gen2/conf/machine/include/rcar-gen2-providers.inc
index 89eba92..413fa50 100644
--- a/meta-rcar-gen2/conf/machine/include/rcar-gen2-providers.inc
+++ b/meta-rcar-gen2/conf/machine/include/rcar-gen2-providers.inc
@@ -2,13 +2,13 @@
# Override that to avoid a long list of build messages stating it is switching from 3.14 to 3.10.
PREFERRED_VERSION_linux-yocto ?= "3.10%"
-# multimedia acceleration uses Gst version 1.2.x, otherwise meta-ivi currently uses 1.4.x
+# multimedia acceleration uses Gst version 1.2.x, otherwise meta-renesas currently uses 1.6.x
require ../../../include/multimedia-control.inc
-PREFERRED_VERSION_gstreamer1.0 = "${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.4.%", d )}"
+PREFERRED_VERSION_gstreamer1.0 = "${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.6.%", d )}"
PREFERRED_VERSION_gstreamer1.0-omx = "${@base_conditional("USE_MULTIMEDIA", "1", "1.0.%", "1.2.%", d )}"
-PREFERRED_VERSION_gstreamer1.0-plugins-bad = '${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.4.%", d )}'
-PREFERRED_VERSION_gstreamer1.0-plugins-base = '${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.4.%", d )}'
-PREFERRED_VERSION_gstreamer1.0-plugins-good = '${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.4.%", d )}'
-PREFERRED_VERSION_gstreamer1.0-plugins-ugly = '${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.4.%", d )}'
-PREFERRED_VERSION_gstreamer1.0-libav = '${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.4.%", d )}'
+PREFERRED_VERSION_gstreamer1.0-plugins-bad = '${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.6.%", d )}'
+PREFERRED_VERSION_gstreamer1.0-plugins-base = '${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.6.%", d )}'
+PREFERRED_VERSION_gstreamer1.0-plugins-good = '${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.6.%", d )}'
+PREFERRED_VERSION_gstreamer1.0-plugins-ugly = '${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.6.%", d )}'
+PREFERRED_VERSION_gstreamer1.0-libav = '${@base_conditional("USE_MULTIMEDIA", "1", "1.2.%", "1.6.%", d )}'
diff --git a/meta-rcar-gen2/recipes-connectivity/gupnp/gupnp-dlna_%.bbappend b/meta-rcar-gen2/recipes-connectivity/gupnp/gupnp-dlna_%.bbappend
new file mode 100644
index 0000000..50cad25
--- /dev/null
+++ b/meta-rcar-gen2/recipes-connectivity/gupnp/gupnp-dlna_%.bbappend
@@ -0,0 +1 @@
+EXTRA_OECONF_append = " --disable-introspection" \ No newline at end of file
diff --git a/meta-rcar-gen2/recipes-core/ncurses/ncurses_5.9.bbappend b/meta-rcar-gen2/recipes-core/ncurses/ncurses_5.9.bbappend
deleted file mode 100644
index 01cad8f..0000000
--- a/meta-rcar-gen2/recipes-core/ncurses/ncurses_5.9.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-do_configure_prepend() {
- # The --enable-pc-files requires PKG_CONFIG_LIBDIR existed
- mkdir -p ${PKG_CONFIG_LIBDIR}
-}
diff --git a/meta-rcar-gen2/recipes-core/systemd/systemd/0001-Add-missing-define-to-header-of-old-porter-kernel.patch b/meta-rcar-gen2/recipes-core/systemd/systemd/0001-Add-missing-define-to-header-of-old-porter-kernel.patch
new file mode 100644
index 0000000..75baa6f
--- /dev/null
+++ b/meta-rcar-gen2/recipes-core/systemd/systemd/0001-Add-missing-define-to-header-of-old-porter-kernel.patch
@@ -0,0 +1,31 @@
+From 2ff62c93fe2b8a0221f199f07060d0bcda46a4b9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jan-Simon=20M=C3=B6ller?= <jsmoeller@linuxfoundation.org>
+Date: Thu, 18 Aug 2016 10:22:27 +0200
+Subject: [PATCH] Add missing define to header of old porter kernel
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
+---
+ src/basic/missing.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/basic/missing.h b/src/basic/missing.h
+index 77be0c8..4fd1595 100644
+--- a/src/basic/missing.h
++++ b/src/basic/missing.h
+@@ -468,6 +468,10 @@ struct btrfs_ioctl_quota_ctl_args {
+ struct btrfs_ioctl_qgroup_limit_args)
+ #endif
+
++#ifndef BTRFS_IOC_QUOTA_RESCAN_WAIT
++#define BTRFS_IOC_QUOTA_RESCAN_WAIT _IO(BTRFS_IOCTL_MAGIC, 46)
++#endif
++
+ #ifndef BTRFS_FIRST_FREE_OBJECTID
+ #define BTRFS_FIRST_FREE_OBJECTID 256
+ #endif
+--
+2.1.4
+
diff --git a/meta-rcar-gen2/recipes-core/systemd/systemd_%.bbappend b/meta-rcar-gen2/recipes-core/systemd/systemd_%.bbappend
new file mode 100644
index 0000000..9cc6bec
--- /dev/null
+++ b/meta-rcar-gen2/recipes-core/systemd/systemd_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://0001-Add-missing-define-to-header-of-old-porter-kernel.patch"
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa-wayland.inc b/meta-rcar-gen2/recipes-graphics/mesa/mesa-wayland.inc
index e9b4459..572c1a7 100644
--- a/meta-rcar-gen2/recipes-graphics/mesa/mesa-wayland.inc
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa-wayland.inc
@@ -2,22 +2,13 @@
PACKAGECONFIG[gles] = "--enable-gles1 --disable-gles2"
PACKAGECONFIG[egl] = "--enable-egl --with-egl-platforms=wayland"
-python do_srcrev_check() {
- if d.getVar('SRCREV') == 'INVALID':
- d.setVar('SRCREV', '"%s"' % d.getVarFlags('SRC_URI')['md5sum'])
-}
-do_patch[prefuncs] += "do_srcrev_check"
-
-# mesa v10.1.3 == ba6dbe2b9cab0b4de840c996b9b6a3ad
-# mesa v10.6.3 == 553e525d2f20ed48fca8f1ec3176fd83
-FILESEXTRAPATHS_append := ":${THISDIR}/mesa_10.1.3/:${THISDIR}/mesa_10.6.3/"
-SRC_URI += " \
- file://0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch;rev="ba6dbe2b9cab0b4de840c996b9b6a3ad" \
- file://0001-dri2-wayland-fixup-gcc5-build.patch;rev="553e525d2f20ed48fca8f1ec3176fd83" \
-"
+FILESEXTRAPATHS_prepend := "${THISDIR}/mesa_10.6.3/:"
+SRC_URI += "file://0001-dri2-Fix-fstat-s_ISHCR-implict-declaration-build-err.patch"
# Disable the gbm modules of mesa
EXTRA_OECONF_rcar-gen2 := "${@'${EXTRA_OECONF}'.replace('--enable-gbm', '--disable-gbm')}"
+PACKAGECONFIG[gbm] = "--disable-gbm"
+
# Remove the gbm and egl packages. These are provided in other recipes.
PACKAGES_remove_rcar-gen2 = "libgbm-dev libgbm libegl-mesa-dev libegl-mesa libegl-dev libegl libgles2-mesa libgles2-mesa-dev"
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch
deleted file mode 100644
index 284ea04..0000000
--- a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.1.3/0001-egl_dri2-fix-wayland_platform-when-drm_platform-is-n.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 6638c55838b8f5186166b7855fdaf41e0a015e88 Mon Sep 17 00:00:00 2001
-From: Emil Velikov <emil.l.velikov@gmail.com>
-Date: Wed, 28 May 2014 14:36:46 +0100
-Subject: [PATCH] egl_dri2: fix wayland_platform when drm_platform is not set
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The build fails with implicit delaration of drmGetCap (xf86drm.h)
-Were we're including the header only when building the DRM_PLATFORM.
-
-Wayland backend can operate without DRM_PLATFORM so replace the
-guard, and fold in drmGetCap() usage to silence compiler warnings.
-
-Cc: Chad Versace <chad.versace@linux.intel.com>
-Cc: Kristian Høgsberg <krh@bitplanet.net>
-Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
----
- src/egl/drivers/dri2/egl_dri2.c | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/src/egl/drivers/dri2/egl_dri2.c b/src/egl/drivers/dri2/egl_dri2.c
-index f7f2da2..c1497b8 100644
---- a/src/egl/drivers/dri2/egl_dri2.c
-+++ b/src/egl/drivers/dri2/egl_dri2.c
-@@ -35,7 +35,7 @@
- #include <fcntl.h>
- #include <errno.h>
- #include <unistd.h>
--#ifdef HAVE_DRM_PLATFORM
-+#ifdef HAVE_LIBDRM
- #include <xf86drm.h>
- #include <drm_fourcc.h>
- #endif
-@@ -2001,7 +2001,7 @@ dri2_bind_wayland_display_wl(_EGLDriver *drv, _EGLDisplay *disp,
- struct wl_display *wl_dpy)
- {
- struct dri2_egl_display *dri2_dpy = dri2_egl_display(disp);
-- int ret, flags = 0;
-+ int flags = 0;
- uint64_t cap;
-
- (void) drv;
-@@ -2012,11 +2012,13 @@ dri2_bind_wayland_display_wl(_EGLDriver *drv, _EGLDisplay *disp,
- wl_drm_callbacks.authenticate =
- (int(*)(void *, uint32_t)) dri2_dpy->vtbl->authenticate;
-
-- ret = drmGetCap(dri2_dpy->fd, DRM_CAP_PRIME, &cap);
-- if (ret == 0 && cap == (DRM_PRIME_CAP_IMPORT | DRM_PRIME_CAP_EXPORT) &&
-+#ifdef HAVE_LIBDRM
-+ if (drmGetCap(dri2_dpy->fd, DRM_CAP_PRIME, &cap) == 0 &&
-+ cap == (DRM_PRIME_CAP_IMPORT | DRM_PRIME_CAP_EXPORT) &&
- dri2_dpy->image->base.version >= 7 &&
- dri2_dpy->image->createImageFromFds != NULL)
- flags |= WAYLAND_DRM_PRIME;
-+#endif
-
- dri2_dpy->wl_server_drm =
- wayland_drm_init(wl_dpy, dri2_dpy->device_name,
---
-1.9.1
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.6.3/0001-dri2-Fix-fstat-s_ISHCR-implict-declaration-build-err.patch b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.6.3/0001-dri2-Fix-fstat-s_ISHCR-implict-declaration-build-err.patch
new file mode 100644
index 0000000..909e0d0
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.6.3/0001-dri2-Fix-fstat-s_ISHCR-implict-declaration-build-err.patch
@@ -0,0 +1,35 @@
+From 2a44bbb7e8604cfb3cb5b04be70e26ad2ecb739e Mon Sep 17 00:00:00 2001
+From: Stephen Lawrence <stephen.lawrence@renesas.com>
+Date: Thu, 10 Mar 2016 14:58:48 +0000
+Subject: [PATCH] dri2: Fix fstat, s_ISHCR implict declaration build error
+
+platform_wayland.c in Mesa 10.6.3 can fail to build with
+the following build errors:
+a/2_10.6.3-r0/mesa-10.6.3/src/egl/drivers/dri2/platform_wayland.c:847:4: error: implicit declaration of function 'fstat' [-Werror=implicit-function-declaration]
+| if (fstat(fd, &render))
+| ^
+/mesa/2_10.6.3-r0/mesa-10.6.3/src/egl/drivers/dri2/platform_wayland.c:850:4: error: implicit declaration of function 'S_ISCHR' [-Werror=implicit-function-declaration]
+| if (!S_ISCHR(render.st_mode))
+| ^
+| cc1: some warnings being treated as errors
+
+Fix the error by including sys/stat.h
+---
+ src/egl/drivers/dri2/platform_wayland.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/egl/drivers/dri2/platform_wayland.c b/src/egl/drivers/dri2/platform_wayland.c
+index 9914b68..131e0ec 100644
+--- a/src/egl/drivers/dri2/platform_wayland.c
++++ b/src/egl/drivers/dri2/platform_wayland.c
+@@ -37,6 +37,7 @@
+ #include <fcntl.h>
+ #include <xf86drm.h>
+ #include <sys/mman.h>
++#include <sys/stat.h>
+
+ #include "egl_dri2.h"
+ #include "egl_dri2_fallbacks.h"
+--
+1.9.1
+
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.6.3/0001-dri2-wayland-fixup-gcc5-build.patch b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.6.3/0001-dri2-wayland-fixup-gcc5-build.patch
deleted file mode 100644
index 7e29bb1..0000000
--- a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.6.3/0001-dri2-wayland-fixup-gcc5-build.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From c219bad8412666983867d5144a4b552acaf5d827 Mon Sep 17 00:00:00 2001
-From: Yannick Gicquel <yannick.gicquel@iot.bzh>
-Date: Wed, 6 Jan 2016 14:04:23 +0100
-Subject: [PATCH] dri2: wayland: fixup gcc5 build
-
-Some standards headers were missing for fstat() syscall.
-
-Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
----
- src/egl/drivers/dri2/platform_wayland.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/egl/drivers/dri2/platform_wayland.c b/src/egl/drivers/dri2/platform_wayland.c
-index 9914b68..f12a70a 100644
---- a/src/egl/drivers/dri2/platform_wayland.c
-+++ b/src/egl/drivers/dri2/platform_wayland.c
-@@ -36,6 +36,8 @@
- #include <unistd.h>
- #include <fcntl.h>
- #include <xf86drm.h>
-+#include <sys/types.h>
-+#include <sys/stat.h>
- #include <sys/mman.h>
-
- #include "egl_dri2.h"
---
-1.9.1
-
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend b/meta-rcar-gen2/recipes-graphics/mesa/mesa_11.%.bbappend
index cd08da8..cd08da8 100644
--- a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa_11.%.bbappend
diff --git a/meta-rcar-gen2/recipes-kernel/linux-libc-headers/linux-libc-headers_3.10.bb b/meta-rcar-gen2/recipes-kernel/linux-libc-headers/linux-libc-headers_3.10.bb
index f4de23e..a1de59c 100644
--- a/meta-rcar-gen2/recipes-kernel/linux-libc-headers/linux-libc-headers_3.10.bb
+++ b/meta-rcar-gen2/recipes-kernel/linux-libc-headers/linux-libc-headers_3.10.bb
@@ -1,5 +1,6 @@
require recipes-kernel/linux-libc-headers/linux-libc-headers.inc
+EXTRA_OEMAKE = "-e MAKEFLAGS="
KORG_ARCHIVE_COMPRESSION = "xz"
COMPATIBLE_MACHINE = "(alt|gose|koelsch|lager|porter|silk)"
PV_append = "+git${SRCREV}"
diff --git a/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb b/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
index 01700f7..841e4fd 100644
--- a/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
+++ b/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
@@ -1,6 +1,8 @@
require ../../include/rcar-gen2-modules-common.inc
require ../../include/omx-components-control.inc
+inherit remove-libtool
+
LICENSE = "CLOSED"
DEPENDS = "mmngr-kernel-module mmngr-user-module \
vspm-kernel-module vspm-user-module \