summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-rcar-gen2/recipes-graphics/wayland/weston/weston-workaround-for-egl-no-display.patch27
-rw-r--r--meta-rcar-gen2/recipes-graphics/wayland/weston_1.8.0.bbappend8
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/wayland/weston/weston-workaround-for-egl-no-display.patch b/meta-rcar-gen2/recipes-graphics/wayland/weston/weston-workaround-for-egl-no-display.patch
new file mode 100644
index 0000000..3133d2f
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/wayland/weston/weston-workaround-for-egl-no-display.patch
@@ -0,0 +1,27 @@
+--- a/src/gl-renderer.c 2016-01-27 08:49:43.328882567 +0000
++++ b/src/gl-renderer.c 2016-01-27 08:56:31.807915324 +0000
+@@ -2127,7 +2127,11 @@
+ {
+ const char *extensions;
+
++#ifndef EGL_DRIVER_NO_EGL_NO_DISPLAY_SUPPORT
+ extensions = eglQueryString(EGL_NO_DISPLAY, EGL_EXTENSIONS);
++#else
++ extensions = NULL;
++#endif
+ if (!extensions) {
+ weston_log("Retrieving EGL client extension string failed.\n");
+ return;
+@@ -2246,8 +2250,12 @@
+ char s[64];
+
+ if (!extensions) {
++#ifndef EGL_DRIVER_NO_EGL_NO_DISPLAY_SUPPORT
+ extensions = (const char *) eglQueryString(
+ EGL_NO_DISPLAY, EGL_EXTENSIONS);
++#else
++ extensions = NULL;
++#endif
+
+ if (!extensions)
+ return 0;
diff --git a/meta-rcar-gen2/recipes-graphics/wayland/weston_1.8.0.bbappend b/meta-rcar-gen2/recipes-graphics/wayland/weston_1.8.0.bbappend
new file mode 100644
index 0000000..383c844
--- /dev/null
+++ b/meta-rcar-gen2/recipes-graphics/wayland/weston_1.8.0.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+# EGL driver does not support the EGL_NO_DISPLAY query parameter
+SRC_URI += " \
+ file://weston-workaround-for-egl-no-display.patch \
+ "
+
+CPPFLAGS_append = " -DEGL_DRIVER_NO_EGL_NO_DISPLAY_SUPPORT=1"