summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/gstreamer/gst-openmax_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-multimedia/gstreamer/gst-openmax_git.bb')
-rw-r--r--common/recipes-multimedia/gstreamer/gst-openmax_git.bb22
1 files changed, 12 insertions, 10 deletions
diff --git a/common/recipes-multimedia/gstreamer/gst-openmax_git.bb b/common/recipes-multimedia/gstreamer/gst-openmax_git.bb
index 3ae3788..3873edd 100644
--- a/common/recipes-multimedia/gstreamer/gst-openmax_git.bb
+++ b/common/recipes-multimedia/gstreamer/gst-openmax_git.bb
@@ -6,7 +6,7 @@ DEFAULT_PREFERENCE = "-1"
DEPENDS = "gstreamer"
RDEPENDS_${PN} = "libomxil"
LICENSE = "LGPLv2.1"
-LICENSE_FLAGS = "commercial"
+LICENSE_FLAGS = "commercial"
require gst-plugins.inc
inherit gettext
@@ -21,15 +21,17 @@ EXTRA_OECONF += "--disable-valgrind"
# for armadillo800eva
SRCREV_armadillo800eva = "43e0be40d82f83308d0a17cd74060b280c30c2a8"
-SRC_URI_armadillo800eva = "git://github.com/matsu/gst-openmax.git \
- file://gst-openmax.conf \
+SRC_URI_armadillo800eva = " \
+ git://github.com/matsu/gst-openmax.git \
+ file://gst-openmax.conf \
"
SRCREV = "3dad1ec6803bb2f2627188ce0e957dbeaa57b1be"
-SRC_URI = "git://github.com/renesas-devel/gst-openmax.git \
- file://0001-base_videodec-change-the-tile-height-for-T-L-address.patch \
- file://0001-Stop-using-deprecated-GLib-thread-API.patch \
- file://disable_configure.patch \
+SRC_URI = " \
+ git://github.com/renesas-devel/gst-openmax.git \
+ file://0001-base_videodec-change-the-tile-height-for-T-L-address.patch \
+ file://0001-Stop-using-deprecated-GLib-thread-API.patch \
+ file://disable_configure.patch \
"
S = "${WORKDIR}/git/"
@@ -39,12 +41,12 @@ CPPFLAGS += "-Wno-deprecated-declarations"
EXTRA_OECONF := "${@'${EXTRA_OECONF}'.replace('--disable-experimental', '--enable-experimental')}"
do_configure_prepend() {
- (cd ${S}; sh autogen.sh --noconfigure)
+ (cd ${S}; sh autogen.sh --noconfigure)
}
do_install_append_armadillo800eva() {
- install -d ${D}/home/root/.config/
- install -m 644 ${WORKDIR}/gst-openmax.conf ${D}/home/root/.config/.
+ install -d ${D}/home/root/.config/
+ install -m 644 ${WORKDIR}/gst-openmax.conf ${D}/home/root/.config/.
}
FILES_${PN} += "${libdir}/gstreamer-${LIBV}/libgstomx.so /home/root/.config"