summaryrefslogtreecommitdiffstats
path: root/common/recipes-multimedia/libshmeram/libshmeram_0.9.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-multimedia/libshmeram/libshmeram_0.9.4.bb')
-rw-r--r--common/recipes-multimedia/libshmeram/libshmeram_0.9.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/common/recipes-multimedia/libshmeram/libshmeram_0.9.4.bb b/common/recipes-multimedia/libshmeram/libshmeram_0.9.4.bb
new file mode 100644
index 0000000..be4cbf0
--- /dev/null
+++ b/common/recipes-multimedia/libshmeram/libshmeram_0.9.4.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "library for accessing the SH-Mobile MERAM"
+AUTHOR = "Damian Hobson-Garcia <dhobsong@igel.co.jp>"
+BUGTRACKER = ""
+
+SECTION = "libs"
+PRIORITY = "optional"
+
+PR = "r0"
+
+inherit autotools pkgconfig
+
+LICENSE = "LGPLv2.0+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3214f080875748938ba060314b4f727d"
+
+SRCREV = "2d9b1c32e17ddb260d592826a13fd5c8e0bdb763"
+SRC_URI = "git://github.com/renesas-devel/libshmeram.git \
+ file://configfile-path.patch \
+ "
+S = "${WORKDIR}/git/"
+
+DEPENDS = "libuiomux"
+
+do_configure() {
+ autoreconf -ivf ${S}
+ oe_runconf
+}
+
+# install to libshmeram
+FILES_${PN} += "${sysconfdir}/*"