summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen2/recipes-kernel')
-rw-r--r--meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module.bb4
-rw-r--r--meta-rcar-gen2/recipes-kernel/linux/linux.inc4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module.bb b/meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module.bb
index e10710f..e3fea90 100644
--- a/meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module.bb
+++ b/meta-rcar-gen2/recipes-kernel/gles-module/gles-kernel-module.bb
@@ -29,8 +29,8 @@ S_r8a7794 = "${WORKDIR}/eurasia_km"
KERNEL_SRC_PATH_r8a7794 = "eurasiacon/build/linux2/r8a7794_linux/"
TARGET_PATH_r8a7794 = "eurasia_km/eurasiacon/binary2_r8a7794_linux_release/target/kbuild"
-GLES = "${@base_contains('MACHINE_FEATURES', 'rgx', 'rgx', \
- base_contains('MACHINE_FEATURES', 'sgx', 'sgx', '', d), d)}"
+GLES = "${@bb.utils.contains('MACHINE_FEATURES', 'rgx', 'rgx', \
+ bb.utils.contains('MACHINE_FEATURES', 'sgx', 'sgx', '', d), d)}"
RPROVIDES_${PN} += "${GLES}-kernel-module"
RPROVIDES_${PN} += "kernel-module-bc-example kernel-module-pvrsrvkm kernel-module-dc-linuxfb"
diff --git a/meta-rcar-gen2/recipes-kernel/linux/linux.inc b/meta-rcar-gen2/recipes-kernel/linux/linux.inc
index af8d8ac..6d1005f 100644
--- a/meta-rcar-gen2/recipes-kernel/linux/linux.inc
+++ b/meta-rcar-gen2/recipes-kernel/linux/linux.inc
@@ -16,7 +16,7 @@ UDEV_GE_141 ?= "1"
KERNEL_ENABLE_CGROUPS ?= "1"
# combine oe-core way with angstrom DISTRO_TYPE
-DISTRO_TYPE ?= "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "release",d)}"
+DISTRO_TYPE ?= "${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", "debug", "release",d)}"
# Set the verbosity of kernel messages during runtime
# You can define CMDLINE_DEBUG in your local.conf or distro.conf to override this behaviour
@@ -185,7 +185,7 @@ do_configure_prepend() {
kernel_configure_variable BLK_DEV_LOOP y
fi
- if [ "x1" = "x${@base_contains("DISTRO_FEATURES", "usbgadget", "1", "",d)}" ]; then
+ if [ "x1" = "x${@bb.utils.contains("DISTRO_FEATURES", "usbgadget", "1", "",d)}" ]; then
# activate USB-OTG & Gadget
kernel_configure_variable USB_OTG y
kernel_configure_variable USB_RENESAS_USBHS_UDC y