aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2/recipes-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen2/recipes-multimedia')
-rw-r--r--meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config.bb27
-rw-r--r--meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config/COPYING39
-rw-r--r--meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config/asound.state-porter106
-rw-r--r--meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb9
-rw-r--r--meta-rcar-gen2/recipes-multimedia/v4l2apps/media-ctl_git.bb21
5 files changed, 194 insertions, 8 deletions
diff --git a/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config.bb b/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config.bb
new file mode 100644
index 0000000..c7ecfea
--- /dev/null
+++ b/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config.bb
@@ -0,0 +1,27 @@
+SUMMARY = "ALSA sound configuration"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3d5968ae2c5badd70c24075cfe58cc1e"
+
+RDEPENDS_${PN} = "alsa-utils"
+
+COMPATIBLE_MACHINE = "(porter|koelsch)"
+
+FILESEXTRAPATHS_prepend := ":${THISDIR}/alsa-utils-config:"
+
+SRC_URI = "file://COPYING \
+ "
+SRC_URI_append_porter = "file://asound.state-porter"
+SRC_URI_append_koelsch = "file://asound.state-porter"
+# SRC_URI_append_silk = "file://asound.state-silk"
+
+do_configure() {
+ cp ${WORKDIR}/COPYING ${S}
+ cp ${WORKDIR}/asound.state* ${S}/asound.state
+}
+
+do_install() {
+ install -d ${D}/${localstatedir}/lib/alsa
+ install -m 0644 asound.state ${D}/${localstatedir}/lib/alsa
+}
+
+FILES_${PN} += "${localstatedir}"
diff --git a/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config/COPYING b/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config/COPYING
new file mode 100644
index 0000000..c7f9365
--- /dev/null
+++ b/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config/COPYING
@@ -0,0 +1,39 @@
+Copyright © 2015-2016 IoT.bzh
+
+Permission to use, copy, modify, distribute, and sell this software and its
+documentation for any purpose is hereby granted without fee, provided that
+the above copyright notice appear in all copies and that both that copyright
+notice and this permission notice appear in supporting documentation, and
+that the name of the copyright holders not be used in advertising or
+publicity pertaining to distribution of the software without specific,
+written prior permission. The copyright holders make no representations
+about the suitability of this software for any purpose. It is provided "as
+is" without express or implied warranty.
+
+THE COPYRIGHT HOLDERS DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
+OF THIS SOFTWARE.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice (including the next
+paragraph) shall be included in all copies or substantial portions of the
+Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config/asound.state-porter b/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config/asound.state-porter
new file mode 100644
index 0000000..ef6fd33
--- /dev/null
+++ b/meta-rcar-gen2/recipes-multimedia/alsa/alsa-utils-config/asound.state-porter
@@ -0,0 +1,106 @@
+state.rsnddai0ak4642h {
+ control.1 {
+ iface MIXER
+ name 'Digital Playback Volume'
+ value.0 182
+ value.1 182
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 255'
+ dbmin -9999999
+ dbmax 1200
+ dbvalue.0 -2450
+ dbvalue.1 -2450
+ }
+ }
+ control.2 {
+ iface MIXER
+ name 'LINEOUT Mixer DACL'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.3 {
+ iface MIXER
+ name 'Headphone Enable Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.4 {
+ iface MIXER
+ name 'Playback ReConvert Rate'
+ value 48004
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 192000 (step 1)'
+ }
+ }
+ control.5 {
+ iface MIXER
+ name 'DVC Out Playback Volume'
+ value.0 25
+ value.1 25
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 100'
+ }
+ }
+ control.6 {
+ iface MIXER
+ name 'DVC Out Mute Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.7 {
+ iface MIXER
+ name 'Capture ReConvert Rate'
+ value 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 192000 (step 1)'
+ }
+ }
+ control.8 {
+ iface MIXER
+ name 'DVC In Capture Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 100'
+ }
+ }
+ control.9 {
+ iface MIXER
+ name 'DVC In Mute Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+}
diff --git a/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb b/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
index c8623cf..01700f7 100644
--- a/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
+++ b/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
@@ -114,7 +114,6 @@ do_install() {
make install
cp -rf ${S}/OMXR/config/*.txt ${D}/usr/local/config/
cp -rf ${S}/UDF_Linux/include ${D}/usr/local/include
- cp -rf ${S}/UDF_Linux/include/*.h ${STAGING_INCDIR}
cd ${S}/OMXR/lib/
@@ -274,7 +273,6 @@ do_install() {
ln -sf libRSACPDAL_L.so.1.1 libRSACPDAL_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/RSACPD_ADL.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/RSACPD_ADL.h ${STAGING_INCDIR}
fi
if [ "X${MP3_MDW_DECODER}" = "X1" ] ; then
@@ -283,7 +281,6 @@ do_install() {
ln -sf libMP3DLA_L.so.1.4 libMP3DLA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/mp3d_Lib.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/mp3d_Lib.h ${STAGING_INCDIR}
fi
if [ "X${WMA_MDW_DECODER}" = "X1" ] ; then
@@ -292,7 +289,6 @@ do_install() {
ln -sf libWMASTDLA_L.so.1.3 libWMASTDLA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/wmastd_Lib.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/wmastd_Lib.h ${STAGING_INCDIR}
fi
if [ "X${DDD_MDW_DECODER}" = "X1" ] ; then
@@ -301,7 +297,6 @@ do_install() {
ln -sf libRSDACDLA_L.so.1.0 libRSDACDLA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/RSDACD_ADL.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/RSDACD_ADL.h ${STAGING_INCDIR}
fi
if [ "X${ALAC_MDW_DECODER}" = "X1" ] ; then
@@ -310,7 +305,6 @@ do_install() {
ln -sf libALACDLA_L.so.1.0 libALACDLA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/alacd_Lib.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/alacd_Lib.h ${STAGING_INCDIR}
fi
if [ "X${FLAC_MDW_DECODER}" = "X1" ] ; then
@@ -319,7 +313,6 @@ do_install() {
ln -sf libFLACDLA_L.so.1.1 libFLACDLA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/flacd_Lib.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/flacd_Lib.h ${STAGING_INCDIR}
fi
if [ "X${AAC_MDW_ENCODER}" = "X1" ] ; then
@@ -328,13 +321,13 @@ do_install() {
ln -sf libRSAACELA_L.so.2.1 libRSAACELA_L.so
cp -P ${S}/audio_mdw/*.so* ${D}/usr/local/lib/
cp -P ${S}/audio_mdw/RSAACE_AAC.h ${D}/usr/local/include
- cp -P ${S}/audio_mdw/RSAACE_AAC.h ${STAGING_INCDIR}
fi
}
SYSROOT_PREPROCESS_FUNCS += "do_populate_share_lib"
do_populate_share_lib () {
+ sysroot_stage_dir ${D}/usr/local/include ${SYSROOT_DESTDIR}/usr/include
sysroot_stage_dir ${D}/usr/local/lib ${SYSROOT_DESTDIR}/usr/lib
}
diff --git a/meta-rcar-gen2/recipes-multimedia/v4l2apps/media-ctl_git.bb b/meta-rcar-gen2/recipes-multimedia/v4l2apps/media-ctl_git.bb
new file mode 100644
index 0000000..86e5364
--- /dev/null
+++ b/meta-rcar-gen2/recipes-multimedia/v4l2apps/media-ctl_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Media controller control application"
+LICENSE = "LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=d749e86a105281d7a44c2328acebc4b0"
+
+DEPENDS = "linux-libc-headers"
+
+SRC_URI = "git://git.ideasonboard.org/media-ctl.git"
+SRCREV = "a6ec4a37028952ffd6e62eb52648cf66248eb519"
+
+PV = "0.0.1"
+PR = "r4"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-kernel-headers=${STAGING_EXECPREFIXDIR}"
+
+PACKAGES =+ "libmediactl libv4l2subdev"
+FILES_libmediactl = "${libdir}/libmediactl${SOLIBS}"
+FILES_libv4l2subdev = "${libdir}/libv4l2subdev${SOLIBS}"
+