summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen2')
-rw-r--r--meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend6
-rw-r--r--meta-rcar-gen2/recipes-kernel/linux/linux.inc3
-rw-r--r--meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb26
3 files changed, 6 insertions, 29 deletions
diff --git a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
index c5b6a2d..cd08da8 100644
--- a/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
+++ b/meta-rcar-gen2/recipes-graphics/mesa/mesa_10.%.bbappend
@@ -12,6 +12,6 @@ def map_libs(d):
MESATARGET := "${@map_libs(d)}"
include mesa-${MESATARGET}.inc
-# Temporarily disable Cortex A7 optimisation to avoid upstream build issue
-# between YP 1.7 gcc toolchain and Mesa 10.1,x releases.
-TARGET_CC_ARCH_remove_alt = "-mtune=cortex-a7"
+# For R-Car E2 temporarily disable Cortex A7 optimisation to avoid upstream
+# build issue between YP 1.7 gcc toolchain and Mesa 10.1.x releases.
+TARGET_CC_ARCH_remove_r8a7794 = "-mtune=cortex-a7"
diff --git a/meta-rcar-gen2/recipes-kernel/linux/linux.inc b/meta-rcar-gen2/recipes-kernel/linux/linux.inc
index 560bf98..886c2a9 100644
--- a/meta-rcar-gen2/recipes-kernel/linux/linux.inc
+++ b/meta-rcar-gen2/recipes-kernel/linux/linux.inc
@@ -118,6 +118,9 @@ do_configure_prepend() {
kernel_configure_variable QUOTA y
kernel_configure_variable BT y
+ # add uinput for automated testing
+ kernel_configure_variable INPUT_MISC y
+ kernel_configure_variable INPUT_UINPUT y
# Keep this the last line
# Remove all modified configs and add the rest to .config
diff --git a/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb b/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
index 12b3f86..c8623cf 100644
--- a/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
+++ b/meta-rcar-gen2/recipes-multimedia/omx-module/omx-user-module.bb
@@ -332,32 +332,6 @@ do_install() {
fi
}
-do_install_append() {
- if [ "X${MACHINE}" = "Xsilk" -o "X${MACHINE}" = "Xporter" ] ; then
- cd ${S}/OMXR/lib/
-
-# ln -sf libomxr_core.so.0.0.0 libomxr_core.so.2.0.0
-# ln -sf libomxr_core.so.0.0.0 libomxr_core.so.0
-# ln -sf libomxr_mc_cmn.so.0.0.0 libomxr_mc_cmn.so.2.0.0
-# ln -sf libomxr_mc_h264d.so.0.0.0 libomxr_mc_h264d.so.2.0.0
-# ln -sf libomxr_mc_h264d.so.0.0.0 libomxr_mc_h264d.so.0
-# ln -sf libomxr_mc_h264e.so.0.0.0 libomxr_mc_h264e.so.2.0.0
-# ln -sf libomxr_mc_h264e.so.0.0.0 libomxr_mc_h264e.so.0
-# ln -sf libomxr_mc_vecmn.so.0.0.0 libomxr_mc_vecmn.so.2.0.0
-# ln -sf libomxr_mc_vcmn.so.0.0.0 libomxr_mc_vcmn.so.2.0.0
-# ln -sf libomxr_mc_vdcmn.so.0.0.0 libomxr_mc_vdcmn.so.2.0.0
-# ln -sf libuvcs_dec.so.0.0.0 libuvcs_dec.so.1.0.0
-# ln -sf libuvcs_enc.so.0.0.0 libuvcs_enc.so.1.0.0
-# ln -sf libvcp3_avcd.so.0.0.0 libvcp3_avcd.so.1.0.0
-# ln -sf libvcp3_avce.so.0.0.0 libvcp3_avce.so.1.0.0
-# ln -sf libvcp3_mcvd.so.0.0.0 libvcp3_mcvd.so.1.0.0
-# ln -sf libvcp3_mcve.so.0.0.0 libvcp3_mcve.so.1.0.0
-
- # Copy all the symbolic link and lib to destination
- cp -Prf ${S}/OMXR/lib/* ${D}/usr/local/lib
- fi
-}
-
SYSROOT_PREPROCESS_FUNCS += "do_populate_share_lib"
do_populate_share_lib () {