summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen2
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rcar-gen2')
-rw-r--r--meta-rcar-gen2/conf/bblayers.conf.sample26
-rw-r--r--meta-rcar-gen2/conf/conf-notes.txt2
-rw-r--r--meta-rcar-gen2/conf/local.conf.sample398
-rw-r--r--meta-rcar-gen2/recipes-kernel/linux/linux-renesas/0008-drm-rcar-du-r8a7791-disable-interlace-mode.patch26
-rw-r--r--meta-rcar-gen2/recipes-kernel/linux/linux-renesas/0021-drm-rcar-du-r8a7794-disable-interlace-mode.patch26
-rw-r--r--meta-rcar-gen2/recipes-kernel/linux/linux-renesas_3.10.bb2
-rw-r--r--meta-rcar-gen2/scripts/setup_mm_packages.sh56
7 files changed, 536 insertions, 0 deletions
diff --git a/meta-rcar-gen2/conf/bblayers.conf.sample b/meta-rcar-gen2/conf/bblayers.conf.sample
new file mode 100644
index 0000000..b1c9874
--- /dev/null
+++ b/meta-rcar-gen2/conf/bblayers.conf.sample
@@ -0,0 +1,26 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "6"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+
+BBLAYERS ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-yocto \
+ ##OEROOT##/meta-yocto-bsp \
+ ##OEROOT##/../meta-agl/meta-ivi-common \
+ ##OEROOT##/../meta-agl/meta-agl \
+ ##OEROOT##/../meta-openembedded/meta-oe \
+ ##OEROOT##/../meta-openembedded/meta-multimedia \
+ ##OEROOT##/../meta-openembedded/meta-ruby \
+ ##OEROOT##/../meta-renesas \
+ ##OEROOT##/../meta-renesas/meta-rcar-gen2 \
+ ##OEROOT##/../meta-agl-demo \
+ ##OEROOT##/../meta-qt5 \
+ "
+BBLAYERS_NON_REMOVABLE ?= " \
+ ##OEROOT##/meta \
+ ##OEROOT##/meta-yocto \
+ ##OEROOT##/../meta-agl/meta-agl \
+ "
diff --git a/meta-rcar-gen2/conf/conf-notes.txt b/meta-rcar-gen2/conf/conf-notes.txt
new file mode 100644
index 0000000..2a92d55
--- /dev/null
+++ b/meta-rcar-gen2/conf/conf-notes.txt
@@ -0,0 +1,2 @@
+Common target are:
+ agl-demo-platform
diff --git a/meta-rcar-gen2/conf/local.conf.sample b/meta-rcar-gen2/conf/local.conf.sample
new file mode 100644
index 0000000..43857ba
--- /dev/null
+++ b/meta-rcar-gen2/conf/local.conf.sample
@@ -0,0 +1,398 @@
+DISTRO = "poky-agl"
+MACHINE = "porter"
+
+# For running GStreamer on wayland (experimental).
+#
+# Uncoment below if want to use multimedia acceleration on wayland
+#
+#IMAGE_INSTALL_append_porter = " \
+# gstreamer1.0-plugins-bad-waylandsink \
+# "
+
+# Additional plugins to test multimedia acceleration (experimental)
+#
+# Uncoment below if want to use multimedia acceleration
+#
+#IMAGE_INSTALL_append_porter = " \
+# gstreamer1.0-plugins-base-videorate \
+# gstreamer1.0-plugins-base-videotestsrc \
+# gstreamer1.0-plugins-base-audiotestsrc \
+# gstreamer1.0-plugins-base-alsa \
+# gstreamer1.0-plugins-good-autodetect \
+# gstreamer1.0-plugins-good-isomp4 \
+# gstreamer1.0-plugins-good-video4linux2 \
+# gstreamer1.0-plugins-good-videocrop \
+# gstreamer1.0-plugins-bad-asfmux \
+# gstreamer1.0-plugins-bad-fbdevsink \
+# gstreamer1.0-plugins-bad-faad \
+# gstreamer1.0-plugins-bad-videoparsersbad \
+#"
+# for graphics acceleration
+#
+# Uncoment below if want to use multimedia acceleration
+#
+#IMAGE_INSTALL_append_porter = " \
+# libegl libegl-dev libgbm-dev \
+# gles-kernel-module gles-user-module \
+# libdrm-tests \
+# libdrm-kms \
+# "
+
+# for multimedia acceleration
+#
+# Uncoment below if want to use multimedia acceleration
+#
+#IMAGE_INSTALL_append_porter = " \
+# packagegroup-rcar-gen2-multimedia \
+# packagegroup-lcb-oss-codecs \
+# alsa-utils alsa-tools \
+#"
+
+# TODO: When booting weston, someone try to load 'libgbm_kms.so' then
+# fail to boot. It should be 'libgbm_kms.so.1'.
+# Tentatively, it is to install 'libgbm-dev' pkg.
+IMAGE_INSTALL_append = "libgbm-dev"
+
+LICENSE_FLAGS_WHITELIST = "commercial"
+
+# Define the name of multimedia, dtv, graphic test, multimedia-test for bbmask
+BB_MULTIMEDIA_KERNEL_MODULE = "fdpm-kernel-module|mmngr-kernel-module|\
+ mmngrbuf-kernel-module|s3ctl-kernel-module|\
+ uvcs-kernel-module|vspm-kernel-module"
+BB_MULTIMEDIA_USER_MODULE = "fdpm-user-module|mmngr-user-module|\
+ mmngrbuf-user-module|omx-user-module|\
+ s3ctl-user-module|vspm-user-module|libmemcpy"
+BB_MULTIMEDIA_TEST_MODULE = "fdpm-tp-user-module|mmngr-tp-user-module|\
+ mmngrbuf-tp-user-module|s3ctl-tp-user-module|\
+ vspm-tp-user-module"
+BB_GST_PLUGINS = "meta-renesas/meta-rcar-gen2/recipes-multimedia/gstreamer"
+MULTIMEDIA_BB = "${BB_MULTIMEDIA_KERNEL_MODULE}|${BB_MULTIMEDIA_USER_MODULE}|\
+ ${BB_MULTIMEDIA_TEST_MODULE}|${BB_GST_PLUGINS}"
+
+# Enable Multimedia standard pkg
+#MACHINE_FEATURES_append = " multimedia"
+
+# UnMask the multimedia kernel modules
+#BBMASK .= "|${BB_MULTIMEDIA_KERNEL_MODULE}"
+
+# UnMask the multimedia user modules
+#BBMASK .= "|${BB_MULTIMEDIA_USER_MODULE}"
+
+# Include static library in SDK
+SDKIMAGE_FEATURES_append = " staticdev-pkgs"
+
+# Mask the DTV pkgs
+#MACHINE_FEATURES_append = " dtv"
+BBMASK = "dtv-module|ssp-module|scu-module"
+
+# Enable graphic pkgs
+#BBMASK .= "|gles-kernel-module|gles-user-module"
+
+# Mask the multimedia-test
+BBMASK .= "|${BB_MULTIMEDIA_TEST_MODULE}"
+
+# Mask the graphic test
+BBMASK .= "|gles-test-module"
+
+#DISTRO_FEATURES_append = " mm-test"
+#DISTRO_FEATURES_append = " gles-test"
+
+# Enable Gfx Pkgs
+MACHINE_FEATURES_append = " sgx"
+MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
+
+# for Wayland/Weston
+
+PREFERRED_PROVIDER_virtual/libgles1 = ""
+PREFERRED_PROVIDER_virtual/libgles2 = "gles-user-module"
+PREFERRED_PROVIDER_virtual/egl = "libegl"
+PREFERRED_PROVIDER_virtual/libgl = ""
+PREFERRED_PROVIDER_virtual/mesa = ""
+PREFERRED_PROVIDER_libgbm = "libgbm"
+PREFERRED_PROVIDER_libgbm-dev = "libgbm"
+
+# Setting for u-boot Wayland
+UBOOT_MACHINE = "porter_vin_config"
+
+# Addtional Configurations of Optional OMX modules
+
+# OMX Media Component H263 Decoder Library
+#DISTRO_FEATURES_append = " h263dec_lib"
+# OMX Media Component VC-1 Decoder Library
+#DISTRO_FEATURES_append = " vc1dec_lib"
+# OMX Media Component MPEG-4 Decoder Library
+#DISTRO_FEATURES_append = " mpeg4dec_lib"
+# VCP3 Driver Adapted for Linux MPEG-2 Decoder Library
+#DISTRO_FEATURES_append = " mpeg2dec_lib"
+# DivX Decoder Library for Linux
+#DISTRO_FEATURES_append = " divxdec_lib"
+# Encoder Library for Linux
+DISTRO_FEATURES_append = " h264avcenc_lib"
+
+# Configurations of Optional Audio Decoders
+# ARM 5.1ch aacPlus V2 Decoder for Linux
+#DISTRO_FEATURES_append = " aacp2dec_lib"
+# ARM MP3 Decoder for Linux
+#DISTRO_FEATURES_append = " mp3dec_lib"
+# ARM WMA Decoder for Linux
+#DISTRO_FEATURES_append = " wmadec_lib"
+# ARM 5.1ch Dolby Digital Decoder for Linux
+#DISTRO_FEATURES_append = " ddddec_lib"
+# ARM ALAC Decoder for Linux
+#DISTRO_FEATURES_append = " alacdec_lib"
+# ARM FLAC Decoder for Linux
+#DISTRO_FEATURES_append = " flacdec_lib"
+# ARM AAC-LC Decoder Library Sample for Linux
+#DISTRO_FEATURES_append = " aaclcsdec_lib"
+# ARM AAC Encoder for Linux
+#DISTRO_FEATURES_append = " aacenc_lib"
+
+# Configurations of Optional Audio Middlewares
+# ARM 5.1ch aacPlus V2 Decode Middleware for Linux
+#DISTRO_FEATURES_append = " armaccp2dec_mdw"
+# ARM MP3 Decode Middleware for Linux
+#DISTRO_FEATURES_append = " mp3dec_mdw"
+# ARM WMA Decode Middleware for Linux
+#DISTRO_FEATURES_append = " wmadec_mdw"
+# ARM 5.1ch Dolby Digital Decode Middleware for Linux
+#DISTRO_FEATURES_append = " ddddec_mdw"
+# ARM ALAC Decode Middleware for Linux
+#DISTRO_FEATURES_append = " alacdec_mdw"
+# ARM FLAC Decode Middleware for Linux
+#DISTRO_FEATURES_append = " flacdec_mdw"
+# ARM AAC Decode Middleware Sample for Linux
+#DISTRO_FEATURES_append = " aacsdec_mdw"
+# ARM AAC Encode Middleware for Linux
+#DISTRO_FEATURES_append = " aacenc_mdw"
+
+#
+# This file is your local configuration file and is where all local user settings
+# are placed. The comments in this file give some guide to the options a new user
+# to the system might want to change but pretty much any configuration option can
+# be set in this file. More adventurous users can look at local.conf.extended
+# which contains other examples of configuration which can be placed in this file
+# but new users likely won't need any of them initially.
+#
+# Lines starting with the '#' character are commented out and in some cases the
+# default values are provided as comments to show people example syntax. Enabling
+# the option is a question of removing the # character and making any change to the
+# variable as required.
+
+#
+# Machine Selection
+#
+# You need to select a specific machine to target the build with. There are a selection
+# of emulated machines available which can boot and run in the QEMU emulator:
+#
+#MACHINE ?= "qemuarm"
+#MACHINE ?= "qemumips"
+#MACHINE ?= "qemuppc"
+#MACHINE ?= "qemux86"
+#MACHINE ?= "qemux86-64"
+#
+# There are also the following hardware board target machines included for
+# demonstration purposes:
+#
+#MACHINE ?= "beaglebone"
+#MACHINE ?= "genericx86"
+#MACHINE ?= "genericx86-64"
+#MACHINE ?= "mpc8315e-rdb"
+#MACHINE ?= "edgerouter"
+#
+# This sets the default machine to be qemux86 if no other machine is selected:
+MACHINE ??= "qemux86-64"
+
+#
+# Where to place downloads
+#
+# During a first build the system will download many different source code tarballs
+# from various upstream projects. This can take a while, particularly if your network
+# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
+# can preserve this directory to speed up this part of subsequent builds. This directory
+# is safe to share between multiple builds on the same machine too.
+#
+# The default is a downloads directory under TOPDIR which is the build directory.
+#
+#DL_DIR ?= "${TOPDIR}/downloads"
+
+#
+# Where to place shared-state files
+#
+# BitBake has the capability to accelerate builds based on previously built output.
+# This is done using "shared state" files which can be thought of as cache objects
+# and this option determines where those files are placed.
+#
+# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
+# from these files if no changes were made to the configuration. If changes were made
+# to the configuration, only shared state files where the state was still valid would
+# be used (done using checksums).
+#
+# The default is a sstate-cache directory under TOPDIR.
+#
+#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
+
+#
+# Where to place the build output
+#
+# This option specifies where the bulk of the building work should be done and
+# where BitBake should place its temporary files and output. Keep in mind that
+# this includes the extraction and compilation of many applications and the toolchain
+# which can use Gigabytes of hard disk space.
+#
+# The default is a tmp directory under TOPDIR.
+#
+#TMPDIR = "${TOPDIR}/tmp"
+
+#
+# Default policy config
+#
+# The distribution setting controls which policy settings are used as defaults.
+# The default value is fine for general Yocto project use, at least initially.
+# Ultimately when creating custom policy, people will likely end up subclassing
+# these defaults.
+#
+DISTRO ?= "poky"
+# As an example of a subclass there is a "bleeding" edge policy configuration
+# where many versions are set to the absolute latest code from the upstream
+# source control systems. This is just mentioned here as an example, its not
+# useful to most new users.
+# DISTRO ?= "poky-bleeding"
+
+#
+# Package Management configuration
+#
+# This variable lists which packaging formats to enable. Multiple package backends
+# can be enabled at once and the first item listed in the variable will be used
+# to generate the root filesystems.
+# Options are:
+# - 'package_deb' for debian style deb files
+# - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
+# - 'package_rpm' for rpm style packages
+# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
+# We default to rpm:
+PACKAGE_CLASSES ?= "package_rpm"
+
+#
+# SDK/ADT target architecture
+#
+# This variable specifies the architecture to build SDK/ADT items for and means
+# you can build the SDK packages for architectures other than the machine you are
+# running the build on (i.e. building i686 packages on an x86_64 host).
+# Supported values are i686 and x86_64
+#SDKMACHINE ?= "i686"
+
+#
+# Extra image configuration defaults
+#
+# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
+# images. Some of these options are added to certain image types automatically. The
+# variable can contain the following options:
+# "dbg-pkgs" - add -dbg packages for all installed packages
+# (adds symbol information for debugging/profiling)
+# "dev-pkgs" - add -dev packages for all installed packages
+# (useful if you want to develop against libs in the image)
+# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
+# (useful if you want to run the package test suites)
+# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
+# "tools-debug" - add debugging tools (gdb, strace)
+# "eclipse-debug" - add Eclipse remote debugging support
+# "tools-profile" - add profiling tools (oprofile, exmap, lttng, valgrind)
+# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
+# "debug-tweaks" - make an image suitable for development
+# e.g. ssh root access has a blank password
+# There are other application targets that can be used here too, see
+# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
+# We default to enabling the debugging tweaks.
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+
+#
+# Additional image features
+#
+# The following is a list of additional classes to use when building images which
+# enable extra features. Some available options which can be included in this variable
+# are:
+# - 'buildstats' collect build statistics
+# - 'image-mklibs' to reduce shared library files size for an image
+# - 'image-prelink' in order to prelink the filesystem image
+# - 'image-swab' to perform host system intrusion detection
+# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
+# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
+USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+
+#
+# Runtime testing of images
+#
+# The build system can test booting virtual machine images under qemu (an emulator)
+# after any root filesystems are created and run tests against those images. To
+# enable this uncomment this line. See classes/testimage(-auto).bbclass for
+# further details.
+#TEST_IMAGE = "1"
+#
+# Interactive shell configuration
+#
+# Under certain circumstances the system may need input from you and to do this it
+# can launch an interactive shell. It needs to do this since the build is
+# multithreaded and needs to be able to handle the case where more than one parallel
+# process may require the user's attention. The default is iterate over the available
+# terminal types to find one that works.
+#
+# Examples of the occasions this may happen are when resolving patches which cannot
+# be applied, to use the devshell or the kernel menuconfig
+#
+# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
+# Note: currently, Konsole support only works for KDE 3.x due to the way
+# newer Konsole versions behave
+#OE_TERMINAL = "auto"
+# By default disable interactive patch resolution (tasks will just fail instead):
+PATCHRESOLVE = "noop"
+
+#
+# Disk Space Monitoring during the build
+#
+# Monitor the disk space during the build. If there is less that 1GB of space or less
+# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
+# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# of the build. The reason for this is that running completely out of space can corrupt
+# files and damages the build in ways which may not be easily recoverable.
+BB_DISKMON_DIRS = "\
+ STOPTASKS,${TMPDIR},1G,100K \
+ STOPTASKS,${DL_DIR},1G,100K \
+ STOPTASKS,${SSTATE_DIR},1G,100K \
+ ABORT,${TMPDIR},100M,1K \
+ ABORT,${DL_DIR},100M,1K \
+ ABORT,${SSTATE_DIR},100M,1K"
+
+#
+# Shared-state files from other locations
+#
+# As mentioned above, shared state files are prebuilt cache data objects which can
+# used to accelerate build time. This variable can be used to configure the system
+# to search other mirror locations for these objects before it builds the data itself.
+#
+# This can be a filesystem directory, or a remote url such as http or ftp. These
+# would contain the sstate-cache results from previous builds (possibly from other
+# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
+# cache locations to check for the shared objects.
+# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
+# at the end as shown in the examples below. This will be substituted with the
+# correct path within the directory structure.
+#SSTATE_MIRRORS ?= "\
+#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
+#file://.* file:///some/local/dir/sstate/PATH"
+
+
+#
+# Qemu configuration
+#
+# By default qemu will build with a builtin VNC server where graphical output can be
+# seen. The two lines below enable the SDL backend too. This assumes there is a
+# libsdl library available on your build system.
+PACKAGECONFIG_append_pn-qemu-native = " sdl"
+PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
+ASSUME_PROVIDED += "libsdl-native"
+
+
+# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
+# track the version of this file when it was generated. This can safely be ignored if
+# this doesn't mean anything to you.
+CONF_VERSION = "1"
diff --git a/meta-rcar-gen2/recipes-kernel/linux/linux-renesas/0008-drm-rcar-du-r8a7791-disable-interlace-mode.patch b/meta-rcar-gen2/recipes-kernel/linux/linux-renesas/0008-drm-rcar-du-r8a7791-disable-interlace-mode.patch
new file mode 100644
index 0000000..012bc94
--- /dev/null
+++ b/meta-rcar-gen2/recipes-kernel/linux/linux-renesas/0008-drm-rcar-du-r8a7791-disable-interlace-mode.patch
@@ -0,0 +1,26 @@
+From 9fba622435c36541df97c60b2d7ade25039508de Mon Sep 17 00:00:00 2001
+From: Yannick GICQUEL <yannick.gicquel@iot.bzh>
+Date: Tue, 29 Sep 2015 09:02:55 +0200
+Subject: [PATCH] drm: rcar-du: r8a7791: disable interlace mode
+
+Signed-off-by: Yannick GICQUEL <yannick.gicquel@iot.bzh>
+---
+ drivers/gpu/drm/rcar-du/rcar_du_drv.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/gpu/drm/rcar-du/rcar_du_drv.c b/drivers/gpu/drm/rcar-du/rcar_du_drv.c
+index c6b9292..5512c7a 100644
+--- a/drivers/gpu/drm/rcar-du/rcar_du_drv.c
++++ b/drivers/gpu/drm/rcar-du/rcar_du_drv.c
+@@ -443,7 +443,7 @@ static const struct rcar_du_device_info rcar_du_r8a7791_info = {
+ .drgbs_bit = 1,
+ .max_xres = 1920,
+ .max_yres = 1080,
+- .interlace = true,
++ .interlace = false,
+ .lvds0_crtc = BIT(0),
+ .lvds1_crtc = 0,
+ .vspd_crtc = BIT(0) | BIT(1),
+--
+1.9.1
+
diff --git a/meta-rcar-gen2/recipes-kernel/linux/linux-renesas/0021-drm-rcar-du-r8a7794-disable-interlace-mode.patch b/meta-rcar-gen2/recipes-kernel/linux/linux-renesas/0021-drm-rcar-du-r8a7794-disable-interlace-mode.patch
new file mode 100644
index 0000000..751e657
--- /dev/null
+++ b/meta-rcar-gen2/recipes-kernel/linux/linux-renesas/0021-drm-rcar-du-r8a7794-disable-interlace-mode.patch
@@ -0,0 +1,26 @@
+From 66ea15820ce0a4d093ec7d8a3c4c788f3e5b4bc7 Mon Sep 17 00:00:00 2001
+From: Yannick GICQUEL <yannick.gicquel@iot.bzh>
+Date: Mon, 28 Sep 2015 20:46:30 +0200
+Subject: [PATCH] drm: rcar-du: r8a7794: disable interlace mode
+
+Signed-off-by: Yannick GICQUEL <yannick.gicquel@iot.bzh>
+---
+ drivers/gpu/drm/rcar-du/rcar_du_drv.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/gpu/drm/rcar-du/rcar_du_drv.c b/drivers/gpu/drm/rcar-du/rcar_du_drv.c
+index f7da606..c48d16d 100644
+--- a/drivers/gpu/drm/rcar-du/rcar_du_drv.c
++++ b/drivers/gpu/drm/rcar-du/rcar_du_drv.c
+@@ -650,7 +650,7 @@ static const struct rcar_du_device_info rcar_du_r8a7794_info = {
+ .drgbs_bit = 0,
+ .max_xres = 1920,
+ .max_yres = 1080,
+- .interlace = true,
++ .interlace = false,
+ .lvds0_crtc = 0,
+ .lvds1_crtc = 0,
+ .vspd_crtc = BIT(0),
+--
+1.9.1
+
diff --git a/meta-rcar-gen2/recipes-kernel/linux/linux-renesas_3.10.bb b/meta-rcar-gen2/recipes-kernel/linux/linux-renesas_3.10.bb
index 5d7e9f4..b287f3f 100644
--- a/meta-rcar-gen2/recipes-kernel/linux/linux-renesas_3.10.bb
+++ b/meta-rcar-gen2/recipes-kernel/linux/linux-renesas_3.10.bb
@@ -45,6 +45,7 @@ SRC_URI_append_porter = " \
file://0005-ARM-shmobile-porter-Sound-DMA-support-via-SRC-on-DTS.patch \
file://0006-ARM-shmobile-porter-Sound-DMA-support-via-DVC-on-DTS.patch \
file://0007-ARM-shmobile-porter-Fix-audio-clk-master-to-SSI-and-.patch \
+ file://0008-drm-rcar-du-r8a7791-disable-interlace-mode.patch \
"
SRC_URI_append_silk = " \
@@ -67,6 +68,7 @@ SRC_URI_append_silk = " \
file://0018-porter-can-support.patch \
file://0019-i2c-busses-rcar-Workaround-arbitration-loss-error.patch \
file://0020-Silk-Remove-I2C1-clock-from-clk_enables.patch \
+ file://0021-drm-rcar-du-r8a7794-disable-interlace-mode.patch \
"
S = "${WORKDIR}/git"
diff --git a/meta-rcar-gen2/scripts/setup_mm_packages.sh b/meta-rcar-gen2/scripts/setup_mm_packages.sh
new file mode 100644
index 0000000..9fed901
--- /dev/null
+++ b/meta-rcar-gen2/scripts/setup_mm_packages.sh
@@ -0,0 +1,56 @@
+#!/bin/bash
+
+MM_PKG_REVISION="20150727"
+
+MM_PKG_NAME="R-Car_Series_Evaluation_Software_Package"
+MM_PKG_USERLAND="for_Linux"
+MM_PKG_KERNEL="of_Linux_Drivers"
+
+ZIP_1=${MM_PKG_NAME}_${MM_PKG_USERLAND}-${MM_PKG_REVISION}.zip
+ZIP_2=${MM_PKG_NAME}_${MM_PKG_KERNEL}-${MM_PKG_REVISION}.zip
+
+COPY_GFX_SCRIPT=copy_gfx_software_$1.sh
+COPY_MM_SCRIPT=copy_mm_software_lcb.sh
+
+test -f ${XDG_CONFIG_HOME:-~/.config}/user-dirs.dirs && source ${XDG_CONFIG_HOME:-~/.config}/user-dirs.dirs
+DOWNLOAD_DIR=${XDG_DOWNLOAD_DIR:-$HOME/Downloads}
+
+function copy_mm_packages() {
+ if [ ! -d binary-tmp ]; then
+ if [ -f $DOWNLOAD_DIR/$ZIP_1 -a -f $DOWNLOAD_DIR/$ZIP_2 ]; then
+ mkdir binary-tmp
+ cd binary-tmp
+ unzip -o $DOWNLOAD_DIR/$ZIP_1
+ unzip -o $DOWNLOAD_DIR/$ZIP_2
+ cd ..
+ else
+ echo -n "The graphics and multimedia acceleration packages for "
+ echo -e "the R-Car M2 Porter board can be download from :"
+ echo -e " <http://www.renesas.com/secret/r_car_download/rcar_demoboard.jsp>"
+ echo -e
+ echo -n "These 2 files from there should be store in your"
+ echo -e "'$DOWNLOAD_DIR' directory."
+ echo -e " $ZIP_1"
+ echo -e " $ZIP_2"
+ return -1
+ fi
+ fi
+
+ if [ -f meta-renesas/meta-rcar-gen2/$COPY_GFX_SCRIPT ]; then
+ cd meta-renesas/meta-rcar-gen2/
+ ./$COPY_GFX_SCRIPT ../../binary-tmp
+ cd ../..
+ else
+ echo "scripts to copy GFX drivers for '$1' not found."
+ return -1
+ fi
+
+ if [ -f meta-renesas/meta-rcar-gen2/$COPY_MM_SCRIPT ]; then
+ cd meta-renesas/meta-rcar-gen2/
+ ./$COPY_MM_SCRIPT ../../binary-tmp
+ cd ../..
+ else
+ echo "scripts to copy MM software for '$1' not found."
+ return -1
+ fi
+}