summaryrefslogtreecommitdiffstats
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-03-21 09:49:28 -0400
committerScott Murray <scott.murray@konsulko.com>2022-03-21 17:01:27 -0400
commit23eaf7da1f7d252aefddf9e41e52c745b7433b50 (patch)
tree131e1559b9bad3eb3886b262fe22f0fc8ee07c6a /app/CMakeLists.txt
parentb869bdb6b30a0a46efd33eb927f2a7658864807c (diff)
Changes: - Remove the autobuild scripts and config.xml used by the app framework widget build. - Update the CMake files to just build a "cluster-gauges" binary and install it into /usr/bin by default. - Remove the code in main.cpp that handled reading the WebSocket command-line arguments and passing them to binding related code. Bug-AGL: SPEC-4306 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6c6c80836931af3355f1b793a20e5ccdf683c48d
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt35
1 files changed, 17 insertions, 18 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 8e039e6..3bc2b4f 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -1,5 +1,5 @@
###########################################################################
-# Copyright 2018 Konsulko Group
+# Copyright 2018,2022 Konsulko Group
#
# Author: Scott Murray <scott.murray@konsulko.com>
#
@@ -16,33 +16,32 @@
# limitations under the License.
###########################################################################
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-set(CMAKE_AUTOMOC ON)
+project(cluster-gauges VERSION 2.0.0 LANGUAGES CXX)
+
+if(CMAKE_VERSION VERSION_LESS "3.7.0")
+ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+endif()
+set(OE_QMAKE_PATH_EXTERNAL_HOST_BINS $ENV{OE_QMAKE_PATH_HOST_BINS})
+
set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
-find_package(Qt5 COMPONENTS Core Gui QuickControls2 WebSockets QuickWidgets REQUIRED)
+find_package(Qt5 COMPONENTS Core Gui QuickControls2 QuickWidgets REQUIRED)
find_package(PkgConfig REQUIRED)
qt5_add_resources(RESOURCES cluster-gauges.qrc images/images.qrc)
-PROJECT_TARGET_ADD(cluster-gauges)
-
-add_executable(${TARGET_NAME}
+add_executable(${PROJECT_NAME}
main.cpp
${RESOURCES}
)
-set_target_properties(${TARGET_NAME} PROPERTIES
- LABELS "EXECUTABLE"
- PREFIX ""
- COMPILE_FLAGS "${QLIBWINMGR_FLAGS} ${EXTRAS_CFLAGS} -DFOR_AFB_BINDING"
- LINK_FLAGS "${BINDINGS_LINK_FLAG}"
- LINK_LIBRARIES "${EXTRAS_LIBRARIES}"
- OUTPUT_NAME "${TARGET_NAME}"
-)
-
-target_link_libraries(${TARGET_NAME}
+target_link_libraries(${PROJECT_NAME}
Qt5::QuickControls2
Qt5::QuickWidgets
- ${QLIBWINMGR_LIBRARIES}
)
+
+install(TARGETS ${PROJECT_NAME} DESTINATION bin)