summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-03-07 15:46:22 -0500
committerScott Murray <scott.murray@konsulko.com>2022-03-07 15:50:02 -0500
commitbe95c2a9466d03dda01cb882a70458aac81f36e4 (patch)
treed32e477a91cfc9c78316dd5a69473e02a692004c /CMakeLists.txt
parentcb34b2e7e8916f83b1af8282ed689856a8c40231 (diff)
Changes: - Remove the autobuild scripts and config.xml used by the app framework widget build. - Update the CMake files to just build a "xdg-cluster-receiver" binary and install it into /usr/bin by default. - Bumped agl-compositor protocols version requirement to 0.0.20 to work with current AGL. - Remove the code in main.cpp that handled reading the WebSocket command-line arguments and passing them to binding related code. Bug-AGL: SPEC-4283 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I8c9bd3af9ce16f29f24282b89985c0d4d5d9c922
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b61d900..4685915 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,6 @@
###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
+# Copyright 2015,2016,2017 IoT.bzh
+# Copyright 2022 Konsulko Group
#
# Author: romain Forlot <romain.forlot@iot.bzh>
#
@@ -18,5 +19,4 @@
CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
-project(xdg-cluster-receiver)
-include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
+add_subdirectory(app)