summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-03-07 15:51:15 -0500
committerScott Murray <scott.murray@konsulko.com>2022-03-07 15:54:23 -0500
commitb5622ce91307589b03ad5d903214b47ff2277e48 (patch)
treeb6ec6bc48522cbbf720c0a621692a0251143b38f /CMakeLists.txt
parent0fc2ae068b0440cfd885f4a934db203680972fe0 (diff)
Changes: - Remove the autobuild scripts and config.xml used by the app framework widget build. - Update the CMake files to just build a "qt-cluster-receiver" binary and install it into /usr/bin by default. - Remove the code in main.cpp that handled reading the WebSocket command-line arguments and passing them to binding related code. Also removed the now unnecessary port and token caching in surface.{hpp,cpp}. Bug-AGL: SPEC-4283 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I88979f6049212ff790014b9674a87c4c0a582ccb
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bf284f7..4685915 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,6 @@
###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
+# Copyright 2015,2016,2017 IoT.bzh
+# Copyright 2022 Konsulko Group
#
# Author: romain Forlot <romain.forlot@iot.bzh>
#
@@ -18,4 +19,4 @@
CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
-include(${CMAKE_CURRENT_SOURCE_DIR}/conf.d/cmake/config.cmake)
+add_subdirectory(app)