summaryrefslogtreecommitdiffstats
path: root/ahl-policy/CMakeLists.txt
diff options
context:
space:
mode:
authorTai Vuong <tvuong@audiokinetic.com>2017-11-03 18:55:54 -0400
committerTai Vuong <tvuong@audiokinetic.com>2017-11-03 18:55:54 -0400
commit68f1187061c28ecf6439b4dd465f4d256529dc55 (patch)
tree5c86b5c00cda5d183a7dce47622a294a1b9179cb /ahl-policy/CMakeLists.txt
parentb929cdf5d0b27915e84e174c81ffd7e2b2f1beda (diff)
various bug fix, add alsa configuration file to match with Hal control
Diffstat (limited to 'ahl-policy/CMakeLists.txt')
-rw-r--r--ahl-policy/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/ahl-policy/CMakeLists.txt b/ahl-policy/CMakeLists.txt
index aa3ab9c..346669d 100644
--- a/ahl-policy/CMakeLists.txt
+++ b/ahl-policy/CMakeLists.txt
@@ -23,6 +23,11 @@ PROJECT_TARGET_ADD(ahl-policy)
# Define project Targets
ADD_LIBRARY(${TARGET_NAME} STATIC ahl-policy.c)
+
+ if($ENV{AK_DEMO})
+ add_definitions(-DAK_POLICY_DEMO)
+ endif()
+
# Define target includes
TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
PUBLIC ${GLIB_PKG_INCLUDE_DIRS}