summaryrefslogtreecommitdiffstats
path: root/htdocs/CMakeLists.txt
diff options
context:
space:
mode:
authorTai Vuong <tvuong@audiokinetic.com>2017-08-25 15:32:14 -0400
committerTai Vuong <tvuong@audiokinetic.com>2017-08-25 15:32:14 -0400
commit5c26597129668e57534199ffc566c68ee6672a7e (patch)
treefd0c6c113ab1d03183b260a5587349bd1b75b244 /htdocs/CMakeLists.txt
parent831e6b828179225116b52064ce9d7703b3202fad (diff)
add doc and example files
Diffstat (limited to 'htdocs/CMakeLists.txt')
-rw-r--r--htdocs/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/htdocs/CMakeLists.txt b/htdocs/CMakeLists.txt
new file mode 100644
index 0000000..e85ca3c
--- /dev/null
+++ b/htdocs/CMakeLists.txt
@@ -0,0 +1,44 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+
+##################################################
+# HTML Testing Files
+##################################################
+PROJECT_TARGET_ADD(htdocs)
+
+ file(GLOB SOURCE_FILES "*.html" "*.js" "*.jpg" "*.css")
+
+ add_custom_target(${TARGET_NAME}
+ DEPENDS ${PROJECT_PKG_BUILD_DIR}/${TARGET_NAME}
+ )
+
+ add_custom_command(
+ DEPENDS ${SOURCE_FILES}
+ OUTPUT ${PROJECT_PKG_BUILD_DIR}/${TARGET_NAME}
+ COMMAND mkdir -p ${PROJECT_PKG_BUILD_DIR}/${TARGET_NAME}
+ COMMAND touch ${PROJECT_PKG_BUILD_DIR}/${TARGET_NAME}
+ COMMAND cp -r ${SOURCE_FILES} ${PROJECT_PKG_BUILD_DIR}/${TARGET_NAME}
+ )
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "HTDOCS"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+