summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorAshok Sidipotu <ashok.sidipotu@collabora.com>2023-12-07 14:14:01 +0100
committerAshok Sidipotu <ashok.sidipotu@collabora.com>2023-12-08 13:12:14 +0100
commitf6eb75678f6c08c4eb3fe232f814834319611ff7 (patch)
tree0da6c467fb0e2ffcbceb0ccdfe64fc2ef05cd11e /src/meson.build
parent82c1c0ab04219f9453f1b3a14a9754068e360583 (diff)
audiomixer: Add gain controls
- Add Equalizer gain controls. - Add a simple app to test the controls. Bug-AGL: SPEC-4931 Change-Id: Ib33eb0e829747c401861e99acd67291462ec6a97 Signed-off-by: Ashok Sidipotu <ashok.sidipotu@collabora.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 6c50419..d8b57be 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -60,3 +60,12 @@ executable('agl-service-audiomixer',
'-D_XOPEN_SOURCE=700',
],
install_dir : get_option('sbindir'))
+
+executable('audio-mixer-test',
+ ['audiomixertest.c', 'audiomixer.c'],
+ dependencies: [dependency('wireplumber-0.4')],
+ install: true,
+ c_args : [
+ '-D_XOPEN_SOURCE=700',
+ ],
+ install_dir : get_option('bindir'))