summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2024-09-04 11:01:39 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-09-09 11:13:12 +0200
commit67bfd23df1bbfcc162e656278b14c27e2fd8d52d (patch)
tree377c1d0fc12a6eab85cf81ece25ae5887c46876f /src/meson.build
parent4cdc01f44814cfed6a32accce9a0db03feebbb93 (diff)
audiomixer: update to work with WirePlumber 0.5
This update also brings improvements to the initialization state management, so that ensure_controls() is guaranteed to return after all the relevant controls have been discovered. Previously there were cases that ensure_controls() would return without having discovered the role-based sinks or the equalizer sink. Bug-AGL: SPEC-4934 Change-Id: If3acca37c98ae6ff5ef811b7634951d12bf1d030 Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index d8b57be..3d213a5 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,16 +1,17 @@
boost_dep = dependency('boost',
version : '>=1.72',
modules : [ 'thread', 'filesystem', 'program_options', 'log', 'system' ])
+wireplumber_dep = dependency('wireplumber-0.5')
cpp = meson.get_compiler('cpp')
grpcpp_reflection_dep = cpp.find_library('grpc++_reflection')
service_dep = [
boost_dep,
+ wireplumber_dep,
dependency('openssl'),
dependency('threads'),
dependency('libsystemd'),
- dependency('wireplumber-0.4'),
dependency('protobuf'),
dependency('grpc'),
dependency('grpc++'),
@@ -63,7 +64,7 @@ executable('agl-service-audiomixer',
executable('audio-mixer-test',
['audiomixertest.c', 'audiomixer.c'],
- dependencies: [dependency('wireplumber-0.4')],
+ dependencies: wireplumber_dep,
install: true,
c_args : [
'-D_XOPEN_SOURCE=700',