summaryrefslogtreecommitdiffstats
path: root/binding/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2018-06-04 14:31:40 -0400
committerMatt Porter <mporter@konsulko.com>2018-06-14 10:58:53 -0400
commit2cf42de672004e56063f83ad26da8fec1c757e43 (patch)
tree15b0d0be0f2cf6f716389c3725740aff44ec8f15 /binding/CMakeLists.txt
parent830bf99eba883c93cf231b661310da57eeb54a88 (diff)
Initial Bluetooth PBAP binding
Supports the following features: - retrieval of phonebook contacts - retrieval of call history (incoming/outgoing/missed/combined lists) - retrieval of individual contact entry by handle - search for contact by phone number Bug-AGL: SPEC-1437 Change-Id: I1d0d5c4c02e5ba4a5db1bcfc932421fd9d478426 Signed-off-by: Matt Porter <mporter@konsulko.com>
Diffstat (limited to 'binding/CMakeLists.txt')
-rw-r--r--binding/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/binding/CMakeLists.txt b/binding/CMakeLists.txt
new file mode 100644
index 0000000..2477384
--- /dev/null
+++ b/binding/CMakeLists.txt
@@ -0,0 +1,43 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+# contrib: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(bluetooth-pbap-binding)
+
+ # Define project Targets
+ add_library(bluetooth-pbap-binding MODULE
+ bluetooth-pbap-binding.c
+ gdbus/freedesktop_dbus_properties_interface.c
+ gdbus/obex_client1_interface.c
+ gdbus/obex_phonebookaccess1_interface.c
+ gdbus/obex_session1_interface.c
+ gdbus/obex_transfer1_interface.c)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX "afb-"
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME} ${link_libraries})
+
+ include_directories(gdbus)