summaryrefslogtreecommitdiffstats
path: root/binding-bluetooth/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2018-10-30 19:41:53 -0700
committerMatt Ranostay <matt.ranostay@konsulko.com>2018-11-12 03:58:47 -0800
commit93f9937300ce2ae1f45d3362d6c1a3180e0743a8 (patch)
tree49983702697c8f0437b7fcff22b0255d3ced0e13 /binding-bluetooth/CMakeLists.txt
parent45d4198af0c314cdcd3d489429953a5b93de988b (diff)
binding: bluetooth: initial commit of binding rewrite
Bug-AGL: SPEC-1630 Change-Id: I33cfec70283fa29f47b76f9e6be3e8e6cd6a2f54 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'binding-bluetooth/CMakeLists.txt')
-rw-r--r--binding-bluetooth/CMakeLists.txt41
1 files changed, 0 insertions, 41 deletions
diff --git a/binding-bluetooth/CMakeLists.txt b/binding-bluetooth/CMakeLists.txt
deleted file mode 100644
index 7461824..0000000
--- a/binding-bluetooth/CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-# contrib: Romain Forlot <romain.forlot@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Add target to project dependency list
-PROJECT_TARGET_ADD(bluetooth-binding)
-
- # Define project Targets
- add_library(${TARGET_NAME} MODULE
- bluetooth-api.c
- bluetooth-manager.c
- bluetooth-agent.c
- lib_agent.c
- bluez-client.c
- lib_bluez.c)
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX "libafm-"
- LABELS "BINDING"
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME} ${link_libraries})
-