summaryrefslogtreecommitdiffstats
path: root/CAN-binder/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-05-05 18:28:49 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-05-05 18:28:49 +0200
commite49eed2b1fffced9f5f8d2b997bb6b987cf208f3 (patch)
tree290083dbd1e0ec9d4c2a99063527ecf72394b6b8 /CAN-binder/CMakeLists.txt
parent792d96c11c6b43df1349edcf245a8a31072fa71d (diff)
Update CMake following app-template repo update
Change-Id: Ib24f8c2000f78f5f6fea3126e52f34570e4eee18 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CAN-binder/CMakeLists.txt')
-rw-r--r--CAN-binder/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CAN-binder/CMakeLists.txt b/CAN-binder/CMakeLists.txt
index 56e7860f..f834f240 100644
--- a/CAN-binder/CMakeLists.txt
+++ b/CAN-binder/CMakeLists.txt
@@ -21,8 +21,13 @@ CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
include(${CMAKE_CURRENT_SOURCE_DIR}/etc/config.cmake)
include(${CMAKE_CURRENT_SOURCE_DIR}/etc/macros.cmake)
+MESSAGE(STATUS "INSTALL PREFIX: ${CMAKE_INSTALL_PREFIX}")
+
# Bindings to compile
# --------------------
-search_targets()
+project_subdirs_add()
+
+project_targets_populate()
+project_package_build()
-build_widget()
+project_closing_msg()