summaryrefslogtreecommitdiffstats
path: root/CAN-binder/low-can-binding/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-06-20 10:24:05 +0000
committerRomain Forlot <romain.forlot@iot.bzh>2017-06-20 10:24:05 +0000
commit32e25cbca210a359b09768537b6f443fe90a3070 (patch)
tree3309794c15d8a8f8e9c1c08cad072ee1378813ba /CAN-binder/low-can-binding/CMakeLists.txt
parent76c43dec62b2e21cd6446360c00d4fe6b437533f (diff)
Separation Generator to a dedicated repo
Change-Id: Id94831651c3266861435272a6e36c7884bef2c45 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CAN-binder/low-can-binding/CMakeLists.txt')
-rw-r--r--CAN-binder/low-can-binding/CMakeLists.txt67
1 files changed, 0 insertions, 67 deletions
diff --git a/CAN-binder/low-can-binding/CMakeLists.txt b/CAN-binder/low-can-binding/CMakeLists.txt
deleted file mode 100644
index cd38fca3..00000000
--- a/CAN-binder/low-can-binding/CMakeLists.txt
+++ /dev/null
@@ -1,67 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-# contrib: Romain Forlot <romain.forlot@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Add target to project dependency list
-PROJECT_TARGET_ADD(low-can)
-
- # Define project Targets
- add_library(${TARGET_NAME} MODULE
- binding/${TARGET_NAME}-hat.cpp
- binding/${TARGET_NAME}-cb.cpp
- binding/${TARGET_NAME}-subscription.cpp
- binding/application.cpp
- binding/application-generated.cpp
- can/can-bus.cpp
- can/can-message-set.cpp
- can/can-message-definition.cpp
- can/can-message.cpp
- can/can-signals.cpp
- can/can-decoder.cpp
- diagnostic/diagnostic-message.cpp
- diagnostic/diagnostic-manager.cpp
- diagnostic/active-diagnostic-request.cpp
- utils/signals.cpp
- utils/openxc-utils.cpp
- utils/timer.cpp
- utils/socketcan.cpp
- utils/socketcan-raw.cpp
- utils/socketcan-bcm.cpp
- utils/config-parser.cpp)
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX "afb-"
- LABELS "BINDING"
- LINK_FLAGS ${BINDINGS_LINK_FLAG}
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- ini-config
- openxc-message-format
- uds-c
- isotp-c
- bitfield-c
- ${link_libraries})
-
- # installation directory
- INSTALL(TARGETS ${TARGET_NAME}
- LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})
-