summaryrefslogtreecommitdiffstats
path: root/CAN-binder/low-can-binding/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-04-29 18:13:28 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2017-04-29 18:13:28 +0200
commit6b5723d18a3c4d4f583e6edab38fe7731cda13bf (patch)
treee150b7e5a07a996f05af0f7c3a15b490d7d2146d /CAN-binder/low-can-binding/CMakeLists.txt
parentd5a9a1906e1487d1af3526d23b7415e81c989caf (diff)
Adapt CMake files to use new capabilities with widget
Change-Id: I88a1ef090b7ce40c833c5780f5a481876ff7ea09 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'CAN-binder/low-can-binding/CMakeLists.txt')
-rw-r--r--CAN-binder/low-can-binding/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CAN-binder/low-can-binding/CMakeLists.txt b/CAN-binder/low-can-binding/CMakeLists.txt
index a68ea2a2..ddac1db6 100644
--- a/CAN-binder/low-can-binding/CMakeLists.txt
+++ b/CAN-binder/low-can-binding/CMakeLists.txt
@@ -29,8 +29,9 @@ PROJECT_TARGET_ADD(low-can-binding)
# Binder exposes a unique public entry point
SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
PREFIX ""
+ LABELS "BINDING"
LINK_FLAGS ${BINDINGS_LINK_FLAG}
- OUTPUT_NAME ${TARGET_NAME}
+ OUTPUT_NAME ${TARGET_NAME}
)
# Library dependencies (include updates automatically)
@@ -41,11 +42,10 @@ PROJECT_TARGET_ADD(low-can-binding)
uds-c
isotp-c
bitfield-c
- ${link_libraries}
- )
+ ${link_libraries})
+
+ populate_widget()
# installation directory
INSTALL(TARGETS ${TARGET_NAME}
LIBRARY DESTINATION ${BINDINGS_INSTALL_DIR})
-
- build_widget("BINDING") \ No newline at end of file