summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Douheret <sebastien.douheret@iot.bzh>2017-03-20 15:34:01 +0100
committerSebastien Douheret <sebastien.douheret@iot.bzh>2017-03-20 15:34:01 +0100
commitdb3dea9a59746b26b966b022d046ec8e44c37539 (patch)
tree5c6145d539579d3fab7770a2518c72eba81e70ea /CMakeLists.txt
parente2d3b306a08bb536209f9a101315ad036186fe4c (diff)
Use bash script to generate doc instead of cmake
Signed-off-by: Sebastien Douheret <sebastien.douheret@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 0 insertions, 26 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05fbd5fc..233ee695 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,29 +20,3 @@
cmake_minimum_required(VERSION 3.3)
project(low-can-binding)
add_subdirectory(src)
-
-add_custom_command(
- OUTPUT ${PROJECT_NAME}.pdf
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND gitbook install
- COMMAND gitbook pdf docs ${PROJECT_NAME}.pdf
-)
-add_custom_target(pdf
- DEPENDS ${PROJECT_NAME}.pdf)
-
-add_custom_command(
- OUTPUT _book
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND gitbook install
- COMMAND gitbook serve
-)
-add_custom_target(serve
- DEPENDS _book)
-
-add_custom_command(
- OUTPUT docs_doxygen
- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
- COMMAND doxygen CAN_signaling.doxygen
-)
-add_custom_target(doxygen
- DEPENDS docs_doxygen) \ No newline at end of file