summaryrefslogtreecommitdiffstats
path: root/low-can-binding/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-01-06 18:30:03 -0500
committerScott Murray <scott.murray@konsulko.com>2021-01-11 17:57:06 -0500
commit9e23caa4c56259044604c38f107f7c637001b846 (patch)
tree12c843eb45e2783f2009f81c4d61707efd56fdd5 /low-can-binding/CMakeLists.txt
parent64092acda9a8581034c61732754eddee39f747ca (diff)
Add back the ini-config and config-parser code that existed previously, and use it in binding init to over-ride the device mapping from the controller JSON if /etc/dev-mapping.conf exists. This restores the documented behavior, and is needed for the existing AGL demo platform support and soon CI. Additionally: - Add code to validate the active_message_set, diagnostic_bus, and bus device mapping configuration values. - The above required moving plugin loading before the configuration callback in the controller configuration, but this change seems rational in that everything required by the generated plugin code is already initialized before then, and it makes validating the configuration possible without adding an extra callback. - Add logging of the used CAN bus to device mappings at info level to ease debugging any future issues. - Tweak the log level of the missing configuration file message to info from error, since it is a legitimate mode of operation if relying on the default bus values in the controller JSON. Bug-AGL: SPEC-3755 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I440f5e0fc85be41f7c4c1f47d824a403525a18f9
Diffstat (limited to 'low-can-binding/CMakeLists.txt')
-rw-r--r--low-can-binding/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/low-can-binding/CMakeLists.txt b/low-can-binding/CMakeLists.txt
index 38ac4b3d..7f73339d 100644
--- a/low-can-binding/CMakeLists.txt
+++ b/low-can-binding/CMakeLists.txt
@@ -59,6 +59,7 @@ PROJECT_TARGET_ADD(low-can)
#utils/socketcan-raw.cpp
utils/socketcan-bcm.cpp
utils/converter.cpp
+ utils/config-parser.cpp
)
add_library(${TARGET_NAME} SHARED ${SOURCES_LIB} ${SOURCES_J1939} ${SOURCES_ISOTP})
@@ -70,6 +71,7 @@ PROJECT_TARGET_ADD(low-can)
)
TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ ini-config
openxc-message-format
uds-c
isotp-c