summaryrefslogtreecommitdiffstats
path: root/low-can-binding/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2019-11-26 16:18:41 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2019-11-28 16:11:46 +0100
commit451598fa9ce4e57a00c9312c04839e0b3dcdf320 (patch)
tree49a6341d98f1a6ca34320d5f6512ac08df1cccfd /low-can-binding/CMakeLists.txt
parent68d8bc019fab3e73654a330baf6b8dd7c11859ca (diff)
Integrate the J1939 features : address claiming and write.
This commit allows to write J1939 messages and add the management of the address claiming. Bug-AGL: SPEC-2386 Bug-AGL: SPEC-2976 Signed-off-by: Arthur Guyader <arthur.guyader@iot.bzh> Change-Id: I1bb95a7ba6f6ebe463319c3972d9d46897181d51 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'low-can-binding/CMakeLists.txt')
-rw-r--r--low-can-binding/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/low-can-binding/CMakeLists.txt b/low-can-binding/CMakeLists.txt
index 71e467d1..63ed99cc 100644
--- a/low-can-binding/CMakeLists.txt
+++ b/low-can-binding/CMakeLists.txt
@@ -51,7 +51,9 @@ PROJECT_TARGET_ADD(low-can)
if(WITH_FEATURE_J1939)
set(SOURCES_J1939
can/message/j1939-message.cpp
- utils/socketcan-j1939.cpp
+ utils/socketcan-j1939/socketcan-j1939.cpp
+ utils/socketcan-j1939/socketcan-j1939-data.cpp
+ utils/socketcan-j1939/socketcan-j1939-addressclaiming.cpp
)
endif()