aboutsummaryrefslogtreecommitdiffstats
path: root/low-can-binding/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2019-06-26 10:34:04 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2019-06-26 17:55:06 +0200
commitd2d2620bbb8f0aad0181e67e9f6affc3d6cb4a51 (patch)
tree13e7c1069252dbadb2b430414f3722132d1d7013 /low-can-binding/CMakeLists.txt
parent82b45e3de8c92816c8080178224c5bd4be60a091 (diff)
Change can_message_t class usage for new j1939
This commit transforms the class can_message_t as the base class and creates two derived classes: j1939_message_t and can_message_t. Bug-AGL: SPEC-2386 Change-Id: I6d3afd8e4f5abff2cd0ec4e9910bd52a2893de76 Signed-off-by: Arthur Guyader <arthur.guyader@iot.bzh> Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh> Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'low-can-binding/CMakeLists.txt')
-rw-r--r--low-can-binding/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/low-can-binding/CMakeLists.txt b/low-can-binding/CMakeLists.txt
index 296fa7d4..5c0ef07e 100644
--- a/low-can-binding/CMakeLists.txt
+++ b/low-can-binding/CMakeLists.txt
@@ -30,7 +30,8 @@ PROJECT_TARGET_ADD(low-can)
can/can-bus.cpp
can/can-message-set.cpp
can/can-message-definition.cpp
- can/can-message.cpp
+ can/message/message.cpp
+ can/message/can-message.cpp
can/can-signals.cpp
can/can-decoder.cpp
can/can-encoder.cpp
@@ -44,11 +45,13 @@ PROJECT_TARGET_ADD(low-can)
#utils/socketcan-raw.cpp
utils/socketcan-bcm.cpp
utils/config-parser.cpp
- binding/application-generated.cpp)
+ binding/application-generated.cpp
+ )
if(WITH_FEATURE_J1939)
set(SOURCES_J1939
- # Empty for the moment to not break the build until all modifications are set
+ can/message/j1939-message.cpp
+ utils/socketcan-j1939.cpp
)
endif()