summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-03-13 17:46:13 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2017-03-16 17:15:55 +0100
commit7abe7ef5336d88736b20b015ae219731d5f42365 (patch)
tree7822dfb03c4242001827ee4f6f8aa4d98826f489 /src/CMakeLists.txt
parent542518e3f4390fcb0d8fb17bcbb14c7eb4335a61 (diff)
Separation of classes in the same file.
Change-Id: Ifc690cc27028659ffaf5a8a2e9caabc1e0718fd4 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3c231401..962b41b7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -79,8 +79,8 @@ add_library(openxc STATIC ${PROJECT_LIBDIR}/openxc-message-format/gen/cpp/openxc
message(STATUS "Creation of ${PROJECT_NAME} binding for AFB-DAEMON")
###########################################################################
-add_library(${PROJECT_NAME} MODULE ${PROJECT_NAME}.cpp configuration.cpp
- can/can-bus.cpp can/can-bus-dev.cpp can/can-message.cpp can/can-signals.cpp can/can-decoder.cpp
+add_library(${PROJECT_NAME} MODULE ${PROJECT_NAME}.cpp configuration.cpp configuration-generated.cpp
+ can/can-bus.cpp can/can-bus-dev.cpp can/can-message-set.cpp can/can-message-definition.cpp can/can-message.cpp can/can-signals.cpp can/can-decoder.cpp
obd2/obd2-signals.cpp obd2/diagnostic-manager.cpp obd2/active-diagnostic-request.cpp
utils/signals.cpp utils/openxc-utils.cpp utils/timer.cpp utils/socket.cpp)
target_link_libraries(${PROJECT_NAME} pthread bitfield uds isotp openxc)