summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-02-23 14:09:30 +0000
committerRomain Forlot <romain.forlot@iot.bzh>2017-02-23 14:09:30 +0000
commitd59970dce571c1753174124326406ec1ff8e2ce8 (patch)
tree9d58203f97dc15353502f49a401fca383b00dd35 /src/CMakeLists.txt
parentb0975e4bfa534153657a7ee8acaee0f950056e97 (diff)
Make binder_interface global variable rather than
pass it over and over through class and functions Change-Id: Ie32d44126a41125c6c45d18663b668328df44e2d Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e1a82ffc..91de0b3d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -40,7 +40,7 @@ add_compile_options(-Werror=implicit-function-declaration)
add_compile_options(-ffunction-sections -fdata-sections)
add_compile_options(-Wl,--as-needed -Wl,--gc-sections)
add_compile_options(-fPIC)
-add_compile_options(-std=c++11)
+add_compile_options(-std=c++11 -D_REENTRANT)
set(CMAKE_C_FLAGS_PROFILING "-g -O0 -pg -Wp,-U_FORTIFY_SOURCE")
set(CMAKE_C_FLAGS_DEBUG "-g -O0 -ggdb -Wp,-U_FORTIFY_SOURCE")