summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-03-07 15:35:37 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2017-03-16 17:09:03 +0100
commitfe846f6698710163af5f2658cc90151259b09d0d (patch)
tree31ffce196635301f05d9231cf653edd53e9dc773 /src/CMakeLists.txt
parent4d5b071ab451260ef9d3cbf393aca0992104b0d7 (diff)
Introducing diagnostic manager class.
It will hold communication through uds-c lib allowing to communication with diagnostic protocol obd2. It is attached to can_bus_dev_t class 'cause it must regularly send CAN message through it. Change-Id: I2d9d8dfaca10e9865bf82b0ae83e65490ca982f8 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a1a32532..b01ee07f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -85,6 +85,7 @@ message(STATUS "Creation of ${PROJECT_NAME} binding for AFB-DAEMON")
###########################################################################
add_library(${PROJECT_NAME} MODULE ${PROJECT_NAME}.cpp
can/can-bus.cpp can/can-message.cpp can/can-signals.cpp can/can-decoder.cpp
+ obd2/obd2-signals.cpp obd2/diagnostic-manager.cpp
utils/signals.cpp utils/openxc-utils.cpp utils/timer.cpp)
target_link_libraries(${PROJECT_NAME} ${EXTRAS_LIBRARIES} bitfield isotp uds openxc pthread)