aboutsummaryrefslogtreecommitdiffstats
path: root/test/afb-test/etc/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2019-11-26 16:18:46 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2019-11-28 16:11:47 +0100
commit420d8d0fee32599381db6e0cd663b16da34e03cd (patch)
treeaa80bc750d8204abc9f6688a9a1d5c0e8016bb9f /test/afb-test/etc/CMakeLists.txt
parent451598fa9ce4e57a00c9312c04839e0b3dcdf320 (diff)
Add tests for J1939 features.
This commit adds tests for the J1939 features. Bug-AGL: SPEC-2386 Bug-AGL: SPEC-2976 Signed-off-by: Arthur Guyader <arthur.guyader@iot.bzh> Change-Id: I2545eb2f9a27561714fc5efcbd885afcb237770d Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'test/afb-test/etc/CMakeLists.txt')
-rw-r--r--test/afb-test/etc/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/afb-test/etc/CMakeLists.txt b/test/afb-test/etc/CMakeLists.txt
index cd4beb91..b4617ac8 100644
--- a/test/afb-test/etc/CMakeLists.txt
+++ b/test/afb-test/etc/CMakeLists.txt
@@ -20,8 +20,12 @@
# Low-CAN test configuration files
##################################################
PROJECT_TARGET_ADD(afb-test-config)
+ if(WITH_FEATURE_J1939)
+ set(J1939_TEST_CONFFILE ",\"low-can_J1939Test.lua\"")
+ endif()
- file(GLOB CONF_FILES "*.json")
+ configure_file("aft-agl-service-low-can.json.in" "aft-agl-service-low-can.json")
+ file(GLOB CONF_FILES "${CMAKE_CURRENT_BINARY_DIR}/*.json")
add_input_files("${CONF_FILES}")