summaryrefslogtreecommitdiffstats
path: root/libs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/CMakeLists.txt')
-rw-r--r--libs/CMakeLists.txt29
1 files changed, 0 insertions, 29 deletions
diff --git a/libs/CMakeLists.txt b/libs/CMakeLists.txt
deleted file mode 100644
index cd29ea83..00000000
--- a/libs/CMakeLists.txt
+++ /dev/null
@@ -1,29 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Add target to project dependency list
-fill_include_dir(${CMAKE_CURRENT_SOURCE_DIR})
-file(GLOB filelist "${CMAKE_CURRENT_SOURCE_DIR}/*")
-foreach(filename ${filelist})
- if(IS_DIRECTORY ${filename})
- STRING(REGEX REPLACE "^.*\/(.*)$" "\\1" shortname ${filename})
- find_source_files(${filename})
- PROJECT_TARGET_ADD(${shortname})
- add_library(${shortname} STATIC ${sources_files})
- endif(IS_DIRECTORY ${filename})
-endforeach() \ No newline at end of file