summaryrefslogtreecommitdiffstats
path: root/low-can-binding/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'low-can-binding/CMakeLists.txt')
-rw-r--r--low-can-binding/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/low-can-binding/CMakeLists.txt b/low-can-binding/CMakeLists.txt
index d09757d6..296fa7d4 100644
--- a/low-can-binding/CMakeLists.txt
+++ b/low-can-binding/CMakeLists.txt
@@ -18,10 +18,11 @@
###########################################################################
# Add target to project dependency list
+
PROJECT_TARGET_ADD(low-can)
# Define project Targets
- add_library(${TARGET_NAME} MODULE
+ set (SOURCES
#binding/${TARGET_NAME}-hat.cpp
binding/${TARGET_NAME}-cb.cpp
binding/${TARGET_NAME}-subscription.cpp
@@ -45,6 +46,14 @@ PROJECT_TARGET_ADD(low-can)
utils/config-parser.cpp
binding/application-generated.cpp)
+ if(WITH_FEATURE_J1939)
+ set(SOURCES_J1939
+ # Empty for the moment to not break the build until all modifications are set
+ )
+ endif()
+
+ add_library(${TARGET_NAME} MODULE ${SOURCES} ${SOURCES_J1939})
+
set(OPENAPI_DEF "binding/low-can-apidef" CACHE STRING "name and path to the JSON API definition without extension")
# Binder exposes a unique public entry point
SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES