summaryrefslogtreecommitdiffstats
path: root/low-can-binding/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'low-can-binding/CMakeLists.txt')
-rw-r--r--low-can-binding/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/low-can-binding/CMakeLists.txt b/low-can-binding/CMakeLists.txt
index cba07bf5..ce66a8c4 100644
--- a/low-can-binding/CMakeLists.txt
+++ b/low-can-binding/CMakeLists.txt
@@ -63,6 +63,12 @@ PROJECT_TARGET_ADD(low-can)
add_library(${TARGET_NAME} SHARED ${SOURCES_LIB} ${SOURCES_J1939} ${SOURCES_ISOTP})
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "LIBRARY"
+ IMPORTED_LOCATION ${CMAKE_CURRENT_BINARY_DIR}/lib${TARGET_NAME}.so
+ )
+
TARGET_LINK_LIBRARIES(${TARGET_NAME}
ini-config
openxc-message-format
@@ -86,6 +92,7 @@ PROJECT_TARGET_ADD(low-can-binding)
PREFIX "afb-"
LABELS "BINDINGV3"
LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ INSTALL_RPATH "$ORIGIN"
OUTPUT_NAME ${TARGET_NAME}
)