summaryrefslogtreecommitdiffstats
path: root/plugins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/CMakeLists.txt')
-rwxr-xr-xplugins/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
index 6d0bc0bf..631c68c1 100755
--- a/plugins/CMakeLists.txt
+++ b/plugins/CMakeLists.txt
@@ -41,3 +41,32 @@ PROJECT_TARGET_ADD(agl-vcar-signals)
bitfield-c
afb-helpers
${link_libraries})
+
+if(WITH_FEATURE_J1939)
+PROJECT_TARGET_ADD(j1939-signals)
+
+ # Define targets
+ ADD_LIBRARY(${TARGET_NAME} MODULE ${TARGET_NAME}.cpp)
+
+ # Alsa Plugin properties
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "PLUGIN"
+ PREFIX ""
+ SUFFIX ".ctlso"
+ OUTPUT_NAME ${TARGET_NAME}
+ )
+
+ target_include_directories(${TARGET_NAME}
+ PRIVATE "../low-can-binding")
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(${TARGET_NAME}
+ low-can
+ ini-config
+ openxc-message-format
+ uds-c
+ isotp-c
+ bitfield-c
+ afb-helpers
+ ${link_libraries})
+endif()