summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Shamanin <andrei.shamanin@orioninc.com>2020-10-16 11:17:53 +0300
committerAndrey Shamanin <andrei.shamanin@orioninc.com>2020-10-16 11:21:30 +0300
commit87c68a6bc0d655e796484d110fa5336322b171d0 (patch)
tree98891fb8c0090e59f7a9b6904a9d59f04e5b0e02 /src/CMakeLists.txt
parent329d8ba3fb46b8afc803ad4a9b286cd26141f2f8 (diff)
Bug-AGL: SPEC-3481 Signed-off-by: Andrey Shamanin <andrei.shamanin@orioninc.com> Change-Id: I071d94a9dc2e1f455119124c1185bf135f4c5b78
Diffstat (limited to 'src/CMakeLists.txt')
-rwxr-xr-xsrc/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index fde17a5..eec5b09 100755
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -16,14 +16,18 @@
PROJECT_TARGET_ADD(cloudproxy-binding)
-add_definitions(-DAFB_BINDING_VERSION=3)
+add_definitions(-DAFB_BINDING_VERSION=3 -D_GNU_SOURCE)
set(BINDING_SOURCES
cloudproxy-bindings.cpp
utils.h
- hmi-debug.h
ClientManager.h
ClientManager.cpp
+ CloudType.h
+ AwsClient.h
+ AwsClient.cpp
+ AzureClient.h
+ AzureClient.cpp
)
set(AZURE_DEP_LIBS iothub_client)