summaryrefslogtreecommitdiffstats
path: root/test/afb-test/CMakeLists.txt
diff options
context:
space:
mode:
authorLeonid Lazarev <leonid.lazarev@orioninc.com>2020-07-09 16:59:44 +0300
committerLeonid Lazarev <leonid.lazarev@orioninc.com>2020-09-10 10:31:30 +0300
commit329d8ba3fb46b8afc803ad4a9b286cd26141f2f8 (patch)
treedf2d117410e98abc20c86f3a35cecdacb53e6793 /test/afb-test/CMakeLists.txt
parent0cecffd4565b52bd8d200f6bc9f4144f244a6515 (diff)
Add tests for cloudproxy service
Test cases for basic functionality verification have been added. Build of the application has been adapted for Cmake templates usage. Bug-AGL: SPEC-3485 Change-Id: Iaa4a5e393ac9971be4176e90fa5aee10a4673cd3 Signed-off-by: Leonid Lazarev <leonid.lazarev@orioninc.com>
Diffstat (limited to 'test/afb-test/CMakeLists.txt')
-rw-r--r--test/afb-test/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/test/afb-test/CMakeLists.txt b/test/afb-test/CMakeLists.txt
new file mode 100644
index 0000000..81ddf88
--- /dev/null
+++ b/test/afb-test/CMakeLists.txt
@@ -0,0 +1,21 @@
+###########################################################################
+# Copyright 2019 Konsulko Group
+#
+# author:Stoyan Bogdanov <stoyan.bogdanov@konsulko.com>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Include any directory not starting with _
+# -----------------------------------------------------
+PROJECT_SUBDIRS_ADD(${PROJECT_SRC_DIR_PATTERN})