summaryrefslogtreecommitdiffstats
path: root/ll-database-binding/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLoïc Collignon <loic.collignon@iot.bzh>2017-12-19 17:14:33 +0100
committerLoïc Collignon <loic.collignon@iot.bzh>2017-12-19 17:14:33 +0100
commite7cf408f6d143724ca84119d35f5091f9c3be702 (patch)
treebc639f4029c39ef95182672640dc6361e9106281 /ll-database-binding/src/CMakeLists.txt
parent1d79465dea704d3b2983db132369c74a5892a3e4 (diff)
renamed api to match better the repo name and the feature provided.
Change-Id: I688950d9da5b3db903815a2869767d00df66b6cf Signed-off-by: Loïc Collignon <loic.collignon@iot.bzh>
Diffstat (limited to 'll-database-binding/src/CMakeLists.txt')
-rw-r--r--ll-database-binding/src/CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/ll-database-binding/src/CMakeLists.txt b/ll-database-binding/src/CMakeLists.txt
index cea11a3..95a481a 100644
--- a/ll-database-binding/src/CMakeLists.txt
+++ b/ll-database-binding/src/CMakeLists.txt
@@ -1,4 +1,4 @@
-PROJECT_TARGET_ADD(ll-database-binding)
+PROJECT_TARGET_ADD(persistence-binding)
find_package(GDBM)
if(DB_FOUND)
@@ -8,11 +8,16 @@ else(DB_FOUND)
endif(DB_FOUND)
include_directories(${DB_INCLUDE_DIR})
-add_library(ll-database-binding MODULE ll-database-binding.c)
-target_link_libraries(ll-database-binding ${DB_LIBRARY})
+add_library(persistence-binding MODULE persistence-binding.c)
+target_link_libraries(persistence-binding ${DB_LIBRARY})
-set_target_properties(ll-database-binding PROPERTIES
+set_target_properties(persistence-binding PROPERTIES
PREFIX "afb-"
LABELS "BINDING"
LINK_FLAGS ${BINDINGS_LINK_FLAG}
OUTPUT_NAME ${TARGET_NAME})
+
+install(TARGETS persistence-binding
+ RUNTIME DESTINATION bin
+ ARCHIVE DESTINATION lib
+ LIBRARY DESTINATION lib) \ No newline at end of file