summaryrefslogtreecommitdiffstats
path: root/test/etc/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederic Marec <frederic.marec@iot.bzh>2018-09-28 09:01:04 +0200
committerFrederic Marec <frederic.marec@iot.bzh>2018-09-28 16:07:21 +0200
commit5663caee2540dbc769d39c1e255c35493169b037 (patch)
tree9b2784c30f3c9a7619bfc94d08d4a04669a848dd /test/etc/CMakeLists.txt
parentd0a4331afd096d89325c213d7e933e96bee5b722 (diff)
Add tests for data persistence binding
Add test tree structures Add tests for persistence binding Add dependency in README.md Change-Id: If3fa3450fa61cd7e440712354b123d02934e2488 Signed-off-by: Frederic Marec <frederic.marec@iot.bzh>
Diffstat (limited to 'test/etc/CMakeLists.txt')
-rw-r--r--test/etc/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/test/etc/CMakeLists.txt b/test/etc/CMakeLists.txt
new file mode 100644
index 0000000..1ee805b
--- /dev/null
+++ b/test/etc/CMakeLists.txt
@@ -0,0 +1,31 @@
+###########################################################################
+# Copyright 2018 IoT.bzh
+#
+# author:Frédéric Marec <frederic.marec@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+##################################################
+# Data persistence test configuration files
+##################################################
+PROJECT_TARGET_ADD(afb-test-config)
+
+ file(GLOB CONF_FILES "*.json")
+
+ add_input_files("${CONF_FILES}")
+
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ LABELS "TEST-CONFIG"
+ OUTPUT_NAME ${TARGET_NAME}
+ ) \ No newline at end of file