summaryrefslogtreecommitdiffstats
path: root/ll-database-binding/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'll-database-binding/src/CMakeLists.txt')
-rw-r--r--ll-database-binding/src/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/ll-database-binding/src/CMakeLists.txt b/ll-database-binding/src/CMakeLists.txt
new file mode 100644
index 0000000..904b857
--- /dev/null
+++ b/ll-database-binding/src/CMakeLists.txt
@@ -0,0 +1,13 @@
+PROJECT_TARGET_ADD(ll-database-binding)
+
+find_package(BerkeleyDB REQUIRED)
+include_directories(${DB_INCLUDE_DIR})
+
+add_library(ll-database-binding MODULE ll-database-binding.c utils.h)
+target_link_libraries(ll-database-binding ${DB_LIBRARY})
+
+set_target_properties(ll-database-binding PROPERTIES
+ PREFIX "afb-"
+ LABELS "BINDING"
+ LINK_FLAGS ${BINDINGS_LINK_FLAG}
+ OUTPUT_NAME ${TARGET_NAME})