aboutsummaryrefslogtreecommitdiffstats
path: root/pam/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pam/CMakeLists.txt')
-rw-r--r--pam/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/pam/CMakeLists.txt b/pam/CMakeLists.txt
index 3953704..5d2de63 100644
--- a/pam/CMakeLists.txt
+++ b/pam/CMakeLists.txt
@@ -1 +1,11 @@
-add_library(agl-identity-usbstick-pam SHARED ) \ No newline at end of file
+
+# Add PAM dependency
+# FIXME: Require PAM, but it's seems there is no find_package.
+set(PAM_INCLUDE_DIR "/usr/include/")
+set(PAM_LIB "/lib64/libpam.so.0")
+include_directories(${PAM_INCLUDE_DIR})
+
+# Add the target
+add_library(agl-identity-usbstick-pam SHARED agl-identity-usbstick-pam.c)
+target_link_libraries(agl-identity-usbstick-pam ${PAM_LIB})
+set_property(TARGET agl-identity-usbstick-pam PROPERTY POSITION_IDENPENDENT_CODE ON)